Installing Security VM returns - "Error: invoking remote method 'DefineSystem' returned exit code 800b"

I'm trying to install Security VM using Windows 2012 R2 Server and Hyper-V and receive the following error:

2018-04-23_16-57-42 [INFO] Starting Sophos for Virtual Environments installer tool
2018-04-23_17-10-51 [INFO] Deploying Security VM
2018-04-23_17-10-51 [INFO] Validating VHD disks before installation
2018-04-23_17-11-08 [INFO] Creating configuration disk
2018-04-23_17-11-08 [INFO] Copying configuration disk to datastore
2018-04-23_17-11-08 [INFO] Copying VHD from C:\Users\<User_I_am_using>\Sophos\Sophos-for-Virtual-Environments-Installer\configureSVM.vhd to F:\VirtualServers\OSM-SophosHV01\configureSVM.vhd, this may take some time..
2018-04-23_17-11-08 [INFO] Set Volume Mount point succeeded
2018-04-23_17-11-08 [INFO] Copying VHD from C:\Users\<User_I_am_using>\Sophos\Sophos-for-Virtual-Environments-Installer\sav-sve-disk1.vhd to F:\VirtualServers\OSM-SophosHV01\sav-sve-disk1.vhd, this may take some time..
2018-04-23_17-11-18 [ERROR] Error: invoking remote method 'DefineSystem' returned exit code 800b
2018-04-23_17-11-18 [INFO] Failed to install Security VM

 

Currently this has been escalated to development, but thought I would post here to see if anyone else has run in to this and found a way around it?

For more details see this post:
https://community.sophos.com/products/endpoint-security-control/f/sophos-endpoint-software/92129/installing-security-vm-returns---error-invoking-remote-method-definesystem-returned-exit-code-800b

 

  • As was mentioned in the other post by someone else, they discovered that "I fixed it by changing the default locations for virtual Hard Disk and virtual Computers in the settings of the Hyper-V Host.  Those were not writeable anymore, because they didn't exist."  

    I checked this and sure enough we had added an SSD based RAID array to the server and moved the VM's over, but the HyperV settings were still pointing to the array of spinning disks which didn't have that folder path any longer.