Talpa binaries for 4.4.0-93-generic included in 9.12.3?

My university has a SAV for Linux license, but only offers a pretty old version (9.12.2) which does not include a talpa binary for my kernel version (4.4.0-93-generic). I'm wondering whether 9.12.3 (which is currently offered free by Sophos), does? Thanks.

  • Hello Evan Remington,

    indeed 9.12.2 is pretty old - did you ask why the don't provide a newer one? As far as protection is concerned the licensed and the free version are the same, the former can be centrally managed though so I wonder what exactly they provide.  The current version is, BTW, 9.13.2.

    An included Binary Pack isn't necessary though, if the requirements are met the installer will build the required modules locally. Or did you already try to install and it failed?

    Christian

  • In reply to QC:

    Hi Christian, thanks for your post.

    Regarding building the required modules locally:

    I tried that a few months ago, following the instructions here :

     
    Checked that I had all of the technical requirements (as best I could).
     
    Ran this command:
    /opt/sophos-av/engine/talpa_select select
     
    and got the following output:
     
    [Talpa-select]
    Copyright (c) 1989-2016 Sophos Limited. All rights reserved.
    Tue Jun 20 19:22:29 2017 GMT
    Linux distribution: [ubuntu]
    Product: [Ubuntu 16.04.2 LTS]
    Kernel: [4.4.0-79-generic]
    Multiprocessor support enabled.
    Searching for source pack...
    Verifying source pack contents...
    Searching for suitable binary pack...
    No suitable binary pack available.
    Preparing for build...
    Extracting sources...
    Configuring build of version 1.21.5...
    Error: Failed to prepare the source code for build. Contact Sophos technical support.

     

    Sophos wouldn't help me directly because of the licensing agreement, and our tech support staff couldn't figure out the problem.

    Regarding the version:

    The software folks have no ETA on when we'll get access to a new version. I believe it is the case that the version provided through my university is centrally managed - I remember at one point I was trying to figure out why one of the processes was using a ton of cycles and discovered that it (mrouter) was part of the "Remote Management Services." Our IT people didn't really have any ideas for why it was happening or how to fix it. A reboot fixed it temporarily but it always came back so I uninstalled.

     

    Pretty poor experience overall, which is why I'm looking into the free version.

  • In reply to Evan Remington:

    Hello Evan Remington,

    so it's not mandatory to use the licensed version.(which is normally kept up to date automatically). 9.13.2 includes packs for 4.4.0 (and also you shouldn't have problems building Talpa locally).

    Christian

  • In reply to QC:

    I'm not sure what you mean by the "licensed version." Are you referring to the version offered through my University?

     

    Can I download 9.13.2? It looks like only 9.12.3 is available for free. If 9.13.2 is available for free, do you mind providing me with a link?

     

    Evan

  • In reply to Evan Remington:

    Hello Evan,

    as to licensed - yes.

    I'm not sure the information on the download page is always up to date - it might be still 9.12.3 or already a newer package.
    Anyway, the free version isn't a sell-out of an older you no longer can offer your paying customers Smile and once installed the installation will update to the currently available (i.e. you don't have to reinstall to update, say, 9.12.3 to 9.13.2. So either the package is already the latest or it will update to a version that will either include the Binary Pack or have the sources that enable you to successfully build the modules.

    Christian