[Sandboxie Beta] Sandboxie Beta 5.31 (Latest version 5.31.2)

All,

Please find Sandboxie Beta 5.31.2 below:

Combined installer 
Sandboxie Beta 64 bit installer 
Sandboxie Beta 32 bit installer 

Changes in 5.31.2
- Internet Explorer new tabs will no longer open a new window instead
- Addressed an issue in which certain installers would not start if triggered via forced folders

Known Issues
 -
Win 7 and 8.1 only - Internet Explorer - Program downloads will not initiate if Sandboxed (no workaround other than using a different browser)

Previous changes
Changes in Sandboxie 5.31.1
- Addressed a permissions issue that would prevent files from downloading or saving when Sandboxed on Windows Fast ring versions 18362/ 1903

To report a problem in this thread, please follow these guidelines:
How to report problems with Sandboxie

  • Looking pretty solid here, and with the newly reinstalled 1903. Phew Big Smile

  • First of all thank you :) Downloading works excellent again with latest beta under 1903.

     

    But there is another issue:

    1 - Sandboxie 5.31.1
    2 - Spotify actual version or earlier doesnt matter
    3 - no AV installed
    4 - Try to install the spotify.exe within the Sandbox, error will be appear "Please install Spotify with a normal account not admin"
    5 - yes under all conditions this error happens
    6 - https://abload.de/img/x1nmkwy.jpg

     

    Furthermore Windows 1607 had the same issue years ago with Spotify and  Sandboxie, guess it isn´t that hard to fix so it would be absolulte pleasure if u guys could fix it again :)

  • In reply to MeTaLxMaNiAC ឴ ឴:

    Hi MeTalxMaNiAC,

    Currently, Spotify is not a supported application, you may want to try installing it on the host, and then running it Sandboxed. 
    We'll keep an eye for any other user reports related to this issue, see if anybody can provide a workaround. If you want me to test it, please provide all of the info as required in the guidelines (however, as covered, can't provide an ETA or guarantee e fix).

    Thanks!

  • Sandboxie Beta 5.31.2 has been uploaded - See first post. 

  • In reply to li wang:

    Hi li wang,

    We have an existing thread about that, created by you:
    https://community.sophos.com/products/sandboxie/f/sandboxie-forum/113097/internet-explorer-11-options-view-source-and-inspece-element-are-not-available

    Please, do not re-post. The devs are aware and if/when a solution is found, the thread will be updated accordingly. 

    Thanks!

  • I am having an issue with running anything through Sandboxie. I've tried 5.26, 5.30 and now the latest beta and get the same results.

    1- Sandboxie 5.31 , Windows 10 x64 bit 1803

    2 - Trying to run Steam

    3 - Just stock defender (I've tried disabling it while installing and running which doesn't change anything)

    4 - Install fresh->Try to run anything->Get error and dialog and nothing else (no dialog for picking program or explorer or anything)

    5 - This occurs with the default sandbox

    6 - 

    SBIE2224 Sandboxed program has crashed: SandboxieRpcSs.exe [DefaultBox]
    SBIE2224 Sandboxed program has crashed: Start.exe [DefaultBox]

    Never presented a dialog to pick a program or anything.

    Thanks!

    Aaron

  • In reply to Aaron Melcher:

    Also notible that after the initial errors I will continually get this until I terminate the running programs in the sandbox:

  • In reply to Aaron Melcher:

    Hi Aaron, 

    This does not sound like it is beta related. But let's have you do the following:

    1) Install the latest beta as listed in the first post of this thread.
    2) Can you confirm if the problem affects any program you are trying to run? 
    3) Follow the guidelines to provide all the required info:How to report problems with Sandboxie
    4
    ( Keep in mind that re-installing Sandboxie does not clear the contents of your Sandbox, so be sure to delete that, and also to test in a new sandbox with default settings 
    5) If the problems persist, please include (aside from the required info) a copy of your Sandboxie config file:
    Configure --> Edit configuration
    Copy-paste the contents in your response.   

    Thanks,

  • In reply to Barb@Sophos:

    While collecting more info I decided to attach a debugger to the process reporting issues ( SandboxieRpcSs.exe ). I checked the callstacks of all the threads and noticed that another program I have running, MaxTo (https://maxto.net), had injected into the process. I closed it to rule it out and now I'm working normally. I use MaxTo to organize my windows on my 4k display. I'll leave it to you to note the conflict and/or address why it would be preventing Sandboxie from running properly.

    Here's the extra info you asked for:

    1)

    2) Yeah I get the SandboxieRpcSs.exe reporting app crash before anything runs through the sandbox

    3) I did follow that guide in the original post, please refer to it

    4) There isn't any files in the sandbox, it is a stock DefaultBox

    5) Here is the Sandboxie.ini
    [GlobalSettings]

    Template=WindowsRasMan
    Template=WindowsLive
    Template=OfficeLicensing
    Template=OfficeClickToRun

    [DefaultBox]

    ConfigLevel=7
    AutoRecover=y
    BlockNetworkFiles=y
    Template=qWave
    Template=WindowsFontCache
    Template=BlockPorts
    Template=LingerPrograms
    Template=Chrome_Phishing_DirectAccess
    Template=Firefox_Phishing_DirectAccess
    Template=AutoRecoverIgnore
    RecoverFolder=%{374DE290-123F-4565-9164-39C4925E467B}%
    RecoverFolder=%Personal%
    RecoverFolder=%Favorites%
    RecoverFolder=%Desktop%
    BorderColor=#00FFFF,ttl
    Enabled=y

    [UserSettings_1D0A0342]

    SbieCtrl_UserName=amelcher
    SbieCtrl_BoxExpandedView=DefaultBox
    SbieCtrl_NextUpdateCheck=1561671419
    SbieCtrl_UpdateCheckNotify=n
    SbieCtrl_ShowWelcome=n
    SbieCtrl_WindowCoords=-32,35,488,549
    SbieCtrl_ActiveView=40021
    SbieCtrl_ProcessViewColumnWidths=250,70,300

  • In reply to Aaron Melcher:

    Hi Aaron,

    Right-click on your Sandbox --> Sandbox settings---> Resource access -->IPC Access --> Direct Access

    Click Add, and paste this:
    *\BaseNamedObjects\MAXTO*
    Ok and apply
    Delete the contents of your Sandbox and re-try. 

    This opens a hole in the Sandbox to allow it to interact with Max To.  Use it at your own discretion, and you'll probably need to test functionality, to ensure everything is fine after opening access to it. 

    Regards,

  • In reply to Barb@Sophos:

    Thanks! That works around the issue.

  • Hi Barb,

    my problem is, that after updating my Windows, Sandboxie no longer worked at all (only got the sandboxie icon with an exclamation mark).
    I installed the latest Beta (.2), and Sandboxie came back alife.

    But when I start a program inside Sandboxie it crashes (all programs, even the browser).

     

    Attached is a screenshot with
    - Sandboxie version
    - Windows version
    - Sandboxie Crash Window

    The windows is the latest version from the insider program, because I wanted to test the WSL 2 :)

    Cheers,
    Torsten

  • In reply to Torsten Held:

    Hi Torsten,

    The latest supported Fast Ring (Insider) version is 18362/ 1903 .

    If you are using anything newer than that, it will most likely trigger problems. We don't support that yet. 

    Regards,

  • Since update 5.31.2 I have some issues:

    SBIE 5.31.2, Windows 10 1903, no AV

    1. Sandboxie runs in priviledged mode (e.g. links cannot be opened from Applications outside the box)

    2. I get the following errors while starting Chrome:

    SBIE2101 ConnectPort (C0000022) access=001F0000 initialized=1
    SBIE2101 ConnectPort (C0000022) access=001F0000 initialized=1
    SBIE2101 ConnectPort (C0000022) access=001F0000 initialized=1