Yet another portable Firefox problem

I use the latest official Mozilla Firefox version and extract the portable version.

It runs perfectly outside the sandbox, and is run with the following cmd line parametres: -private -no-remote -profile "profile1"

When I start it like this:

"C:\Program Files\Sandboxie\Start.exe" "C:\Program Files\Firefox_portable\firefox.exe" -private -no-remote -profile "profile1"

it will give me an error box telling me that "Your Firefox profile is not available" (Free translated, I don't know what it writes in English).

Windows 7 ultimate 32bit, Sandboxie v.5.30

  • Hi Carl,

    Please try the latest beta 5.31.2, as this could be related to the permissions issues:
    SBIE BETA VERSIONS 

    Another possibility: Are you giving Sandboxie access to the FF profile? If so, you may see Firefox stating it is already running (this could happen if running FF on the host while also running FF sandboxed with full profile access). 

    Regards,

  • Hi Barb

    No, the beta version do not help.

    I don't think it has anything to do with permissions.

    My guess is that the profile folder for some reason is not copied into the sandbox, probably because Sandboxie copies the profile folder from \\User\roaming\blabla, which is used by the installable version of Firefox. In this case it may be very difficult for Sandboxie to do the correct thing, because Firefox installable and portable is basically the same thing, so Sandboxie will actually have to read the cmd switches to see which profile folder is used.

    In case you don't know how the genuine Firefox portable handles the profile, here is a short description:

    The -profile "profile1" cmd switch tells Firefox to use the profile located in the folder named "profile1".

    Firefox will create the folder if it is not present as a subfolder to the main program folder.

    I hope this clarifies the error so you can reproduce the fault.

  • In reply to Carl Baj:

    Hi Carl,

    Sandboxie 5.30 has a permissions issue that prevents the sandbox from creating folders/files, so you will need to upgrade to address the creation part of the problem.

    I tested your command and it worked fine on beta 5.31.2 - I tested on Win 7 and 10 just to double check. 
    If you are still experiencing issues, please provide the exact repro steps - using a new Sandbox with default settings- so that I can re-test and better assist you.

    Also include a copy of your configuration file: Configure--> Edit configuration

    Thanks!

  • In reply to Barb@Sophos:

    I have tried with the beta, and it does not help.

    "C:\Program Files\Firefox_portable\Firefox.exe" -private -no-remote -profile "profil1" (works)

    "C:\Program Files\Sandboxie\Start.exe" "C:\Program Files\Firefox_portable\Firefox.exe" -private -no-remote -profile "profil1" (Fails).

    I use Win7 Ult 32bit

    [GlobalSettings]

    Template=Microsoft_Security_Essentials
    Template=7zipShellEx
    Template=ComodoInternetSecurity
    Template=AdobeAcrobatReader
    Template=OfficeLicensing

    [DefaultBox]

    ConfigLevel=7
    AutoRecover=y
    Template=WindowsFontCache
    Template=BlockPorts
    Template=LingerPrograms
    Template=Chrome_Phishing_DirectAccess
    Template=Firefox_Phishing_DirectAccess
    Template=AutoRecoverIgnore
    RecoverFolder=%{374DE290-123F-4565-9164-39C4925E467B}%
    RecoverFolder=%Personal%
    RecoverFolder=%Favorites%
    RecoverFolder=%Desktop%
    BorderColor=#00FFFF,ttl
    Enabled=y
    CopyLimitKb=90000

    [UserSettings_04E2013A]

    SbieCtrl_UserName=jan
    SbieCtrl_BoxExpandedView=DefaultBox
    SbieCtrl_NextUpdateCheck=1564905716
    SbieCtrl_UpdateCheckNotify=y
    SbieCtrl_ShowWelcome=n
    SbieCtrl_WindowCoords=65,151,652,492
    SbieCtrl_ActiveView=40021
    SbieCtrl_ProcessViewColumnWidths=250,70,300
    SbieCtrl_ExplorerWarn=n
    SbieCtrl_TerminateWarn=n
    SbieCtrl_HideWindowNotify=n
    SbieCtrl_ShouldDeleteNotify=n
    SbieCtrl_AutoApplySettings=n

  • In reply to Carl Baj:

    Hi Carl,

    Thanks for the info. When you state it fails, what happens exactly? Can I get a screenshot of what are you seeing? I still cannot repro the profile error message.
    Firefox portable (firefox.exe inside Apps--> Firefox) launches when I invoke it via CMD and send it to Sbie using the same commands you are using - (My FF Portable installation is located on my Desktop, but other than that, it is almost the same command).

    Another question, do you have multiple profiles and/or firefox installations? Anything else I should be adding to the tests?

    The only thing I noticed in your configuration file is that you have a template for Comodo (which is probably your AV), but other than that and the copy limit, everything else looks fine. You may want to try disabling the AV and re-test to see if that affects behavior (but from the message you described, I don't think so, might be worth a shot however). 

    Have you created a new Sandbox with default setting since you upgraded to 5.31.2 ? If not, please give that a try and send Firefox to that specific new sandbox to see if the problem persists. [To send to the new box paste this after the Start command: 
    /box:NameOfTheSandbox ]

    Regards,

  • In reply to Barb@Sophos:

    Here is a screenshot:

    Translated: Your Firefox-profile can not be loaded. It is missing or unavailable.

    Quote: Firefox portable (firefox.exe inside Apps--> Firefox)

    Now, you are using Firefox from Mozilla, and not from Portableapps or similar?

    I don't use Comodo AV, it is just a good old version of the firewall.

    I use M$E AV and have tried to disable it without any change.

    And yes, I have several portable Firefox and Pale Moon browsers on my pc, but they all run completely seperate.

    I have now tried with a new sandbox called Firefox. No change...

  • In reply to Carl Baj:

    Hi Carl,

    Thanks for the screenshot.

    Now, you are using Firefox from Mozilla, and not from Portableapps or similar?

    --> No, I am using FirefoxPortable, as you requested. When you decompress it, it creates a folder with several entries, one being FirefoxPortable. exe, and then others are firefox.exe (which seems to be the one you are using, per your posts), located inside Apps--> Firefox and Firefox64 respectively. You are stating you are using firefox.exe, so it has to be the one inside the Apps-> Firefox folder.
    If you are doing something else, I am going to ask you again to please clarify the steps so that I can test the scenario. Otherwise, I won't be able to help you.
    [I tested FirefoxPortable exe as well, and did not experience any issues - I also created a few test profiles, and successfully invoked one as well a non existent one using the commands you suggested].

    So next course of action, please provide a step-by-step list of what you are doing so I can do the exact same and see if we can figure this out. While you do this, please a) ensure no other programs are running (just to rule out any noise), and b) that you are using a new Sandbox with default settings.
    Be sure to include the locations of the applications you are launching and what is the exact executable name and its version.

    Regarding Comodo, you should remove the template if you are not using it (Configure--> Software compatibility --> un-check it there).

    Regards,

  • In reply to Barb@Sophos:

    Well, I can understand that I have not been clear enough in my first post, although I wrote: I use the latest official Mozilla Firefox version and extract the portable version.

    So, go to Mozilla and download the latest full version in your language (not the web installer): https://www.mozilla.org/en-US/firefox/all/

    Use 7zip to extract the installer. Rename the "Core" folder to something more suitable and delete the setup.exe file.

    Firefox.exe wil be in the main folder. Run it with the cmd I have written in the previous posts

  • In reply to Carl Baj:

    Hi Carl,

    No difference in behavior following your last post (I tired both using the core folder, and then renaming it to "fox"  and re-testing). Much like with FF portable,I did not get any errors.  You are invoking a private tab, so not sure why are you seeing profile messages. You may want to look at your profile configuration and go from there.

    I am leaving this thread open in case we see other similar issues that we can use to troubleshoot / other users can chime in with suggestions. 

    Regards,

  • In reply to Barb@Sophos:

    Hi Barb

     

    This is really odd. I run with default profile in Firefox and Sandboxie, except the max.copy size which I increased because xul.dll is absurd huge in Portableapp's version of Firefox.

    A private tab also needs the profile folder, but I tried without the -private switch anyway, still error.

    I have now tried to run the whole Firefox main folder sandboxed, and then from inside the Sandboxie explorer starting Firefox.exe with the switches. Bingo... it works.

    Does this tell you anything?

  • In reply to Carl Baj:

    Hi Carl,

    As a suggestion, see if you can make a backup of your profiles (you may need to look online to find out if this is actually something that can be done safely), then start over with Firefox (as in remove it and all its data (if you can make a backup)), Create a new Sandbox with default settings , test the behavior:

    If the issue does not occur, then start adding your profiles one at a time to see which one triggers the problem (if applicable).

    If the issue occurs with a fresh version of Firefox you probably want to uninstall Sandboxie and the configuration file. Then re-install the latest beta with a fresh config (it will automatically do this), create a new Sandbox and re-test (uninstalling Sandboxie does not delete your Sandboxes, thus the need to create a new Sandbox for each test).

    If the problem still persists and you want me to test it, provide the exact repro steps, including what's running at the time of the tests, where are your profiles located, as well as any other information that affects Firefox and your Sbie version and configuration, and I will give it another try. 

    Regards,

  • In reply to Barb@Sophos:

    I have no installed Firefox, only portable versions that runs totally separated.

    I just tried your suggestion, fresh Firefox with fresh profile and no add-ons:

    1) Extract the Firefox installer

    2) Run "C:\Program Files\core\firefox.exe" -private -no-remote -profile "profil" to create the profile folder.

    3) Create a new sandbox called Firefox2

    4) Run "C:\Program Files\Sandboxie\Start.exe" /Box:Firefox2 "C:\Program Files\core\firefox.exe" -private -no-remote -profile "profil

    Error

    So, now I should try to reinstall Sandboxie?