Indexing Still Doesn't Work in Sandboxed Outlook 2019

Inside the sandbox, searches (from the Outlook search box) cannot find anything recently downloaded or moved.  I have to run Outlook outside the sandbox long enough for the index to be brought up to date before this will work properly.

I had posted this question some years ago under "Indexing in Outlook 2013 (Click-to-Run)" (https://forums.sandboxie.com/phpBB3/viewtopic.php?f=17&t=25042) -- can't find that old thread now -- but there was no solution at that time.  I vaguely recall that Barb (back in the old thread) opined this would not be fixed for such old software and suggested that I upgrade to a new Windows and Outlook.  Now I'm using Outlook 2019 (still strictly POP3 mail, no IMAP nor Exchange server) under Windows 10 (1909) and Sandboxie 5.33.1 and having the same problem.  Is there now a fix? -- jclarkw

  • I did a lot of experimenting and found something that works for me with Outlook 2019 Home & Small Business accessing Gmail via IMAP using Sandboxie 5.31.6.  Try adding the following to the sandbox you're using for Outlook:


    # Open pipe for Outlook indexing
    OpenIpcPath=*\BaseNamedObjects*\MSSPHTB*

    Based on research, mssphtb.dll is the Windows search email indexer in Outlook.

    Hopefully this will allow you to allow Outlook to index while sandboxed.

     

    FYI, I'm unable to use Sandboxie 5.33.1 or higher because it causes Outlook to fail when performing certificate revocation checks on google certificates for gmail.  I've not found a way around that problem, so I'm stuck at 5.31.6 for now.

  • In reply to R Toll:

    Dear R Toll -- Thanks much for the suggestion.  Will try it out when time... -- jclarkw