[FIXED] Microsoft Accounts

PLEASE I appeal to the expert members for a fix that will allow me to login to my Microsoft accounts.

I know this subject has been raised several times, but PLEASE is there a fix so that

I can login to Outlook email, Skype and the Microsoft Forum.

Windows 10/1903 64 bit and Sandboxie 5.31.6 64 bit

Chrome default browser, Firefox and Opera secondary browsers.

  • Do any technicians or code writers read the forum questions? I've had this same problem for months now. It started two Windows versions ago. I'm currently using Windows 1909, Firefox V 70.0.1 (64-bit) and Sandboxie V 5.31.6 (64-bit). I don't get an error code or message. This has become quite an annoyance. I launch a sandboxed Firefox window and proceed to the Outlook Home page, https://outlook.live.com/owa/ . The trouble starts when I click the sign-in button. The page goes white and freezes. I have to close and restart Firefox. This happens with the Vivaldi browser as well. In the meantime, the only recourse I have to login to Outlook is by using MS Edge. When will  this bug get exterminated? I would think 4-6 months is long enough to find a solution.

     

    One more thing, Sophos was it your intent to buy Sandboxie and run it into the ground. I read on the home page that Sophos had thoughts of discontinuing this product. This was a great piece of security software before you took over. It's been a part of many users PC and laptop security for years. I purchased a lifetime license right from the start of my subscription. It had built a reputation of excellence over the years. Problems and bugs were brought forth and fixed in a timely manner. What a shame that this software is getting the cold shoulder treatment.

    Thank you for listening

  • In reply to Terry Ritivoy:

    FWIW ~ I login to my Outlook webmail outside sandbox and save persistent login cookie.  From my browser sandbox I call my Outlook webmail from bookmarks and I'm already sign'd in.  I have two factor but, my device is allowed.    So, by saving persistent login cookies I'm always sign'd in and have not experienced, as you describe. 

    I launch a sandboxed Firefox window and proceed to the Outlook Home page, https://outlook.live.com/owa/.

    I click on your Outlook Home page link and I'm already sign'd in at https://outlook.live.com/mail/0/inbox

    As always, your mileage may vary.

  • In reply to bj m:

    You stay logged in or on to Outllook all the time? Close the non-sandboxed browser and open a sandboxed browser. When you do you are already logged in but are you "completely" sandboxed? This is decent work around but not the fix we should have. Thanks.

  • In reply to Terry Ritivoy:

    I hear ya'.
    I'm always logged in to my webmail accounts and my non-sensitive sites (e.g., community.sophos.com).
    Just me.

  • In reply to bj m:

    Another thing about this work around is it's fine if you only have one email account through that web service. If you have two accounts I'm not sure if you can stay logged into both on the same server, IE: two "live" or "gmail" etc web based accounts logged in at the same time.

  • In reply to Terry Ritivoy:

    Hmm, I thought issue was limited to Microsoft accounts e.g., Outlook webmail.

    Microsoft Accounts

    PLEASE I appeal to the expert members for a fix that will allow me to login to my Microsoft accounts.

    I just called my second Gmail account from my Firefox sandbox.  I was already in my first Gmail account.  I have two Gmail accounts open. I was already logged in.  I can click between my Gmail webmail account browser tabs.   I'll imagine Gmail login if needed while sandbox'd...is okay.

    And with Yahoo.  I logged in my second Yahoo webmail account.  I was already logged in to my first Yahoo webmail account.  Yahoo appears to allow view to one account, at a time.  But, there's no issue logging in.  So, I can toggle between Yahoo accounts from my Firefox sandbox.  Yahoo login while sandbox'd is okay. 

    And if needed with Chrome.  I imagine I can setup Person 2 user profile.

    And if needed with Firefox.   I imagine I can setup another Firefox profile and or use https://addons.mozilla.org/en-US/firefox/addon/multi-account-containers/

    I posted re "persistent login cookies" as a work-around, just as a work-around. 

    For my simple home setup.... running one Gmail, one Yahoo and one Outlook webmail account daily...."persistent login cookies" works for me, at this time. 

    Regards w Respect

  • In reply to bj m:

    Yes for me the "login" issue is with Outlook web based email. A few years back in the days of Windows Live Mail MS allowed you to login to multiple Live accounts. They stopped that policy as a security item reasoning that if one of your accounts was hacked all your accounts could then be exploited. That's why I have to log out of account 1 and login to account 2 separately. Just saying that's why I brought this forward. Good chat!

  • In reply to Terry Ritivoy:

    For those having issues logging into Microsoft accounts, can you try adding the following line to your sandbox.ini:

    ClosedFilePath=*\cryptngc.dll

  • In reply to Akhilesh@Sophos:

    If it works - brilliant ! But HOW do I access "Sandbox.ini" ?

    If you mean "Sandbox Settings" where do I enter it ?

    It does not work using Settings>Resource Access>COM Access.

    Using Chrome, all my login data for all sites is automatically entered by the Save Password system.

    With a Microsoft site like Outlook.com email, the login screen displays but NO login data shows.

    If I start to enter my login data, the screen goes on "Not responding" and I have to crash the Sandboxied browser and start again.

  • In reply to Yabbadoo:

    Try this: Go to your sandbox settings by Right-clicking on your sandbox:

    Then select "Resource Access"->"File Access"->"Blocked Access":

    Then click "Edit/Add" and type in "*\cryptngc.dll"

    Click on OK to make the changes.

  • In reply to Akhilesh@Sophos:

     - you are brilliant and have solved the Microsoft blocked problem - IT WORKED !!!

    I can now login to my Microsoft accounts perfectly OK using Sandboxie and Chrome's automated passwords and avoid those irritating fiddles.

    I would imagine thousands of Sandboxie users will be grateful to you for this simple fix. I just hope they read this thread.

    A million thanks.

  • In reply to Yabbadoo:

    I'll pass on the thanks to the real people behind the scenes that do the brilliant work. I'm just the messenger.

  • In reply to Akhilesh@Sophos:

    Problem solved! Thank you for the fix. It worked perfectly! I typed, actually copied and pasted, what you wrote without the quotation marks. That was a guess on my part. Once again thank you for your help.

  • In reply to Terry Ritivoy:

    Took a long time with you and I moaning plus others just putting up with it.

    A complete disinterest by Sophos until brilliant  came along and supplied a really simple fix.