SB v5.31.4 "The Windows Installer Service Could Not Be Accessed" when trying to install programs.

So I installed v5.31.4 the other day and everything seemed fine, but now though, I'm trying to install Mumble 1.3.0 and I'm getting this "The Windows Installer Service Could Not Be Accessed" error message.

Can anyone else confirm? I don't know if it was from going Beta 5.31.2 to 5.31.4 change that is now showing me this error or if it's a Windows 10 issue... I'm on the latest W10 1903 build also 18362.356.

Here's the download links for Mumble for you guys to try, let me know if you can get the msi installer to work... let me know your OS build version and SB version too would be helpful.

www.mumble.info/.../

I'd like to know if this works for 5.31.2 but not 5.31.4, or does it not work for both?

Also anyone know where I can download the beta version of SB 5.31.2 in case I need to downgrade to fix this regression?

  • In reply to bj m:

    Even the new version of Sandboxie has this problem.

  • In reply to David B1:

    David B1

    Even the new version of Sandboxie has this problem.


    Hmm, I was replying to the post above mine that has since disappeared.

  • In reply to bj m:

    I tryed to look at resource monitor to search what installers need.

    Letter "b" is censored now? :)  Looks strange

  • This is still not fixed, sigh.

  • In reply to Artem S Tashkinov :

    Many programs that have been installed in sandboxes just before those critical updates in Win10 when particular sensitive things were broken with Sandboxie or even under previous versions of Windows (7, 8, 8.1) still continue functioning flawlessly with any current Win 10 build. But we cannot deploy them afresh within a sandbox anymore. Some users here or in other forums suggested installing such programs on another machine (e.g. virtual one) running Win 7 or Win 8.1  then moving sandboxes back to the actual host system. The next problem is that  specific applications are strictly hardware-dependent, that is why they totally fail to run with hardware changed. And even a VM may be  technically perceived by them   as a different hardware configuration. I personally  use a Win 8.1 instance (the most modern, MS supported but still compatible version) with Sandboxie installed on an virtual drive (VHD(X)) either. But I have added it to the main boot menu of my PC instead of  letting it boot on a virtual machine (there is a lot of information on the internet  on how to do that). Not imperative for each and every application though. This is only to make the hardware set-up recognized by the application 100% identical. Besides that, the installation process runs faster and  more predictable on a real machine than on a virtual one. The bad side is that  two successive physical reboots are needed every time when trying to install anything in that way.

    So, the whole installation procedure shall be as follows then:

    Reboot. Chose the relevant Win 8.1. boot menu item. Install yor desired application sandboxed. Reboot again. Attach your VHD(x) (this is necessary when you have placed  the Sandbox folder on the System disk  under the Win 8.1). Find and move the sandbox containing the installation to the Sandbox folder of your  host system. Attach it to your sandbox list  ( by creating a new sandbox entry named appropriately or by giving the sandbox the name of an already listed one). Run your application sandboxed under the current Win 10 build.

    This might be the only reliable workaround to date.  Unluckily.

  • I'm getting this problem with Windows 10 Pro version 1903 OS build 18362.592.