SB v5.31.4 "The Windows Installer Service Could Not Be Accessed" when trying to install programs.

So I installed v5.31.4 the other day and everything seemed fine, but now though, I'm trying to install Mumble 1.3.0 and I'm getting this "The Windows Installer Service Could Not Be Accessed" error message.

Can anyone else confirm? I don't know if it was from going Beta 5.31.2 to 5.31.4 change that is now showing me this error or if it's a Windows 10 issue... I'm on the latest W10 1903 build also 18362.356.

Here's the download links for Mumble for you guys to try, let me know if you can get the msi installer to work... let me know your OS build version and SB version too would be helpful.

I'd like to know if this works for 5.31.2 but not 5.31.4, or does it not work for both?

Also anyone know where I can download the beta version of SB 5.31.2 in case I need to downgrade to fix this regression?

  • I can confirm this using 5.31.2 beta with no other settings marked or unmarked in default box settings.  Likewise, Windows 10 18362.356 (1903)  Google via "Sandboxie, all versions" will get you a listing of the release versions.  Googling "Sandboxie beta versions" got me the Sandboxie beta 5.31 version page with the 5.31.2 download.   



  • In reply to plat 1098:

    Thanks for confirming that it's not just me, does anyone happen to have a workaround?

    Maybe has any ideas?

  • In reply to Redacted:

    Same issue for me with the same configuration. It happened also with Sandboxie 5.30. It may be related to this Windows update:, or the latest:

    Only workaround for me is to run the program in Comodo sandbox.


  • Hello.

    Windows 10 last updated and sandboxie last update, today.

    I have the same problem:

    I had installed some softwares months or years ago and is today working fine.

    If I try to reinstall the same software or file update, I can not install. Message about windows installer apears.

    For example, today I was reinstaling an update as file inside sandboxie and the same message popup "The Windows Installer Service Could Not Be Accessed". No installation.

    Is there any way to work around?

    Thanks in advance.


  • Hello,

    Same situation, it seems that the latest windows 1903 updates changed something and sanboxie lost the ability to install software. Any software already installed in a sandbox works fine. Tried some online suggestions to try to fix windows installer service in sandbox but none of the worked. Let's hope that someone finds a workaround or maybe a fixed version from sophos because at the moment sandboxie is badly crippled.

  • In reply to Dan H:

    DanH wrote:  it seems that the latest windows 1903 updates changed something and sanboxie lost the ability to install software.

    Um, I can install for example "CCleaner" executable installer sandbox'd.   I cannot install ... msi installer....sandbox'd....same as opening poster. 

  • I can confirm the issue too. One machine with windows 10 build 18362 and SBoxie 5.31.4 throws the installer error. 

    Another machine with Windows 10 build 14393 and SBoxie 5.31.4 lets the installer run just fine.

    So yes it looks to be a windows update issue.

    I also tried all sorts of windows installer repair and other hacks but keep hitting the same wall.

    If anyone finds a workaround, please post. Sandboxie is dead in the water until this is resolved.

  • In reply to ordinaryorange:

    I thought that I found a workaround but no: I was not awake enough, it was not working... 

  • In reply to Sir Toto:

    Hello Sir Toto,

    I tried your trick but it didn't work for me, I still get that message. Maybe I didn't do it right. My steps:

    1. Made a folder on the desktop.

    2. I right-clicked on the folder and opened it up in the default sandbox.

    3. I right-clicked in the sandboxed folder and created a new notepad file.

    4. I opened it, wrote something in it and saved it.

    5. I then copied the msi installer from outside the sandbox into the sandboxed folder.

    6. I run the installer - and got the error message.

    What have I done wrong?


  • In reply to Bellzemos:

    Hello Bellzemos, 

    My bad ! I't not working: I didn't realize that the installer was not running sandboxed the way I did.

    I'm sorry, I should have noticed that.

    My apologies for this false hope...

  • In reply to Sir Toto:

    No need to be sorry, I wish it would work! This is a big problem, I'm unable to install programs under Sandboxie anymore. Will this get fixed (soon)?

  • In reply to Bellzemos:

    Will this get fixed (soon)?


    Barb is gone. Seth doesn't want to reply to questions about community and support. Sophos is neither publishing the source code nor telling when it will be published.

    In this situation, do you really think any problem will get fixed soon?

  • In reply to Pedro López:

    The communication of this company is really very bad. Not just during the time between the beginning of the sandboxie problem and the announcement that it will be made open source, but also after these announcement. When they would answer to the most urgent questions, and tell us a time schedule of making it open source, the discussions in the forum (and also outside in other forums) would be less negative. Missing communication is the real problem here.

  • In reply to Kasia Kassia:

    Um, and you've tested as fix for: