Sophos SafeGuard Authentication Service is not running, no further action possible! on SafeGuard 8.00.0.251 Windows 10

I have a laptop that is in use and after a few months of this laptop being deployed, it has started giving an error on login.

The error is the following: 

Sophos SafeGuard Authentication Service is not running, no further action possible!

We are currently running SafeGuard 8.00.0.251. This laptop was working and bitlocker is enabled. However, after reinstalling the sophos packages, it is still having this issue.

I found an article here that stated that CEIP registry key needs to be changed, but that registry key in windows 10 was already set to "0"

 

Any idea why the sophos client is not running and cannot login?? I am at a loss for why this is happening.

 

Regards,

 

 

  • Hi  

    Please refer to this article Sophos SafeGuard Authentication Service is not running, no further action possible! error displayed. Also, check if the Microsoft updates (Microsoft KB4016446 and KB3185319) were installed. Let me know if this helps resolve your issue. 

    Note: Do let me know if you see any error while starting the SGN Authentication Service.

  • In reply to Haridoss Sreenivasan:

     

    Thank you for the reply

    This is Windows 10, However even still I verified that:

    1.) Forefront is not installed and does not apply.

    2.) The registry key was set properly for "HKLM\System\CurrentControlSet\services\SGNAuthService"

    So, This article is not very helpful, As I have tried it previously.

     

    Additionally, the two KB articles mentioned are not installed because this is a Windows 10 v1607 Build 14393.1480

    Please advise on any additional assistance is appreciated.

     

    Regards,

    Jeff

  • In reply to JeffNero:

    It would appear as if I can manually start the Sophos service after login. Manually via the services app.

    What's happening is the service does not respond and time out after 30000 milliseconds and moves on to finish startup. 

    However, I cannot get the service to start at startup and then it just doesn't launch.

     

    Regards,

    Jeff

  • In reply to JeffNero:

    Well, it appears that the issue is resolved by increasing the Services timeout. as follows:

    1. Go to Start Run > and type regedit
    2. Navigate to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
    3. With the control folder selected, right click in the pane on the right and select new DWORD Value
    4. Name the new DWORD: ServicesPipeTimeout
    5. Right-click ServicesPipeTimeout, and then click Modify
    6. Click Decimal, type '180000', and then click OK
    7. Restart the computer

    Regards,

    Jeff Nero

  • In reply to JeffNero:

    Hi Jeff,

    Thank you for sharing the resolution workaround with us. Am glad that you were able to fix the issue.