Safeguard installation fails

Hi, I have 2 x new Dell E6430 Laptops. We have safeguard 6.01 installed on many other same - and - similar model laptops.

Safeguard appears to go through the installation process correctly, but on rebooting, I get this error: sgn_reboot_error.

if you can't open the link, the text of the error is  

"Safeguard is starting . Please wait..."

i think the important message is

 err=0000e820 - I can't find any instance of this error on the support site or forums.

... other stuff...


I've left a laptop like this for > 24 hours, just in case it was doing something in the background, alas, no joy.

I can't engage the boot-function keys at all - shift F6 etc - doesn't matter how many times I try to reboot, it seems to ignore my key commands. - shift pressed before boot screen, during and after boot screen, tried all sorts of combinations to get the sophos function keys to work

It doesn't seem to matter how the laptop is installed.

I have updated BIOS and all other drivers to latest versions from Dell.

TPM is not enabled.

I have run chkdsk /r from recovery console and also defrag prior to installation. No errors, bad sectors, etc.

First I tried an installation with a ghost image (W7 pro, 32bit etc..) then installed SGN. boom. system halts on reboot.

Then I cleared the disk with DD, did a manual install of windows and apps - nothing special, office, sophos AV, PDF reader, added to domain etc..

I copied the SGN installation folder to the C: drive, reinstalled - the install script does the preinstall first then the client install, then reboots - after a couple of seconds the same message as above appears.

There is a system (boot) partition, however this is NTFS formatted, not RAW, and there is also the usual C: partition.

SGN is being installed with an account that is also a member of the local admins group.

I tried the same process on a second E6430 laptop, the second one installed with Win 7 x64 ultimate (8gb ram) - got the 

exact same error message.

most recently I have managed to run SGNRollback so at least have not had to reinstall the system again, and also have access to the SGN client install logfiles.

What should I try to troubleshoot this? - Any assistance appreciated, I just don't know where to go next.

  • Many of the newer laptops and ultrabooks coming out have the UEFI SafeBoot feature turned on. Can you verify if it's on or off? Also is it using UEFI+Bios to boot or UEFI Only?
  • UEFI is off.

    I have downloaded new software (latest version) - however I don't think that helped

    A new POACFG file has allowed the installation and encryption process to complete - the one I was using previously was v5.6, I did not realise a newer one was available. It would have been handy if this was made available on the same download site as the software

    Thanks for your assistance

  • My company is been deploying the Sophos SafeGuard 6.10 client to our client machines since few months by manual installations.
    Now we are planning to package this and deploy using MDT or Altiris.
    I tried packaging using the switches provided in the admin guide but for some reason after installation, few services and components are not installing.

    This is the batch file I have created for installing:
    sc query | find "SafeGuard"
    if %errorlevel% EQU 0 goto done
    set sysos=86
    set | find "ARCHITECTURE=AMD64"
    if %errorlevel% EQU 0 set sysos=64

    reg query HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\ Windows\CurrentVersion\Uninstall\{D102EA66-BFC5-44B6-A371-54FAF5A1B27B} /f DisplayName | find "Sophos SafeGuard Preinstall"
    if %errorlevel% equ 1 goto newinstall
    if %errorlevel% equ 0 goto cont

    start /wait msiexec /i \\corpfs21\usr-apps$\SG6.1client\SGxClientPreinstall_x%sysos%.msi /qn

    set addfeatures=ADDLOCAL=Client,BaseEncryption,Credent ialProvider,FileShare,SecureDataExchange, ALTERNATE=1 Installdir="%programfiles(x86)%\Sophos\SafeGuard Enterprise"

    start /wait msiexec /i "\\corpfs21\usr-apps$\SG6.1client\SGNClient_x%sysos%.msi" /qn /l*v %temp%\SGNClient.log %addfeatures%
    start /wait msiexec /i "\\corpfs21\usr-apps$\SG6.1client\gym.msi" /qn /forcerestart /L*v %temp%\ClientConfig.log
    This is not installing all the components. but the same files if I manually install, it does work. Once the package runs and I don't see any Sophos screen login.

    The services/components when manually installed are below:
    Base Encryption Service
    Device Encryption Controller
    Kernal Feature Client
    Log services
    Master Application Watch dog
    System Event Manager
    Transport Services.

    Can someone help me for the silent installation of the package to deploy.

  • Hi,


    I am getting the same error.


    What is the solution to resolve this issue??

  • In reply to glenaldo:



    How u resolved this issue ,can i understand ??

    and allowed the file in laptop POACFG 


  • In reply to paresh palav:


    Would you please provide the error you are facing and the version you are currently on? The thread which you are referring to is almost 5 years old. I would suggest you open a new thread and post your query, we will try to help you to resolve your issue.