Windows 10 RDP Redirected Printing Errors - After 8.10.2.55 Update Installed

I have a user who prints to her home printer while connected via RDP to her work PC.  Both home and work PCs are Windows 10, latest 1903, all updates.  Printer is your basic Officejet Pro 8600.  This worked without issue until I updated her client to 8.10.2.55 version, including the 1901 hotfix.  It was impossible to resolve the issue until I fully uninstalled Sophos Encryption.  I tried everything, including turning office Remote Easy Print via GPO and going with the local drivers, matching exactly.  Same issue.  It instantly fails on the office PC, with an immediate error.  Nothing ever makes it to her home PC printer, via print queue, etc.   As soon as I fully uninstall Sophos / Decrypt system, etc.....all RDP printing works to her home printer from her work PC, via RDP.   I re-installed everything again, printing fails.  So I know it's something with the encryption / Sophos Safeguard.   I hate to roll her back to the older version, which I think was 8.0 something...but I may have to if there's no help.

Anyone see this issue or have ideas?

  • Hi  

    Is it giving you any error message? Could you please try the steps provided in this article and see if you are able to print with Safeguard installed? Also,for testing purpose give it a try by excluding the mapped drive for the printers in the File Encryption policy and see if the behavior continues.

  • In reply to Shweta:

    They do have file encryption enabled, but are not using it.   Ironically, they will be soon and that was a feature I added recently to all of their workstations.   But again, I have not enabled any file shares yet.  Let me try the steps from that article and get back to you.   Here is the error, which does appear to be exactly the same as described in the article.  They are on 8.10 already.

     

  • In reply to Nick Ruta:

    Hi  

    We understand your concern regarding the version as well but the problem may occur due to the subversion of the 8.10. I'd request you to apply the workaround mentioned in the KB article suggest by  however, I'd request you to open a support case here as the KB is specifically for the error which appears when files are on network share and they are encrypted.

    Once the case has been opened, please PM us the case number, so we can monitor the case and also mention the steps you followed while troubleshooting the issue in the case.

  • In reply to Jasmin:

    The KB article steps did not fix the problem.  I have opened a case with your online support and am awaiting confirmation of a case number.

  • In reply to Jasmin:

    I am upgrading the management center / server to 8.20 to see if it helps.  I never realized this was available for download.  Once I update this client with the new version, I will let you know if the problem persists.

  • In reply to Jasmin:

    Updated to version 8.20.  Same problem, will not print.  Only get instant error.  I uninstalled ONLY the File Encryption component on the client PC, leaving just Native Device Encryption, and the RDP printing worked normally.  So the issue is definitely the File Encryption component / driver / etc.  I will respond to the Sophos case email now with all of the details.  

  • In reply to Nick Ruta:

    Hi  

    Would you please suggest whether you have installed File encryption Build 29 on the machine where you have an issue? If yes, please refer to this article as build 29 is withdrawn as it has a few issues and bug. We suggest using build 28 which doesn't have such an issue with it.

    I have also received a case number in the DM and I'll keep an eye on the case. 

  • In reply to Jasmin:

    Hi Nick,

    I have reviewed your case and I am glad that printer issue is now resolved.

    The issue was resolved by doing a few registry changes on the affected system.

    Happy Christmas and Happy New Year in Advance!

  • In reply to Jasmin:

    Hey there,

     

    Can you supply those registry changes? I am experiencing this on 8.30 FE.

     

    --Mark