SafeGuard Enterprise: macOS Catalina support

Overview

Apple has released macOS version 10.15 (Catalina) on the 11th of October 2019. SafeGuard version 8.20.0 and previous versions of SafeGuard Disk Encryption and File Encryption for Mac, do not support this new Operating System and may not function correctly.

To be able to use macOS Catalina (10.15) together with SafeGuard Enterprise, you need to install version 8.30 which is currently planned to be available in November 2019.

Note: SafeGuard Enterprise 8.30 will support macOS 10.13, 10.14 and 10.15.

What to do

Sophos is planning to release a new version of SafeGuard, version 8.30, that supports this new operating system, in November 2019.

Until this version is available, we recommend to refrain from updating existing systems to macOS 10.15 or installing a not supported SafeGuard Client on the new Operating System.

Related KBA: https://community.sophos.com/kb/en-us/134791