Sophos Central Endpoint and SEC: Computers fail/hang on boot after the Microsoft Windows April 9, 2019 update. Please follow knowledge base article 133945

Learn about the Benefits of Multi-Factor Authentication (MFA). Turn your MFA on now!

PureMessage 4.0.4 and Exchange 2016 installed on Windows Server 2016 Datacenter-edition

Hi Community,

We are currently running Exchange 2010 with PureMessage 3.1.3.0 on Windows Server 2008R2 Datacenter-edition.

We are in process of upgrading to Exchange 2016 and has installed 16 Exchange 2016-servers all on Windows Server 2016 Datacenter-edition in a DAG.

Now we found out, that on 6th. of November 2018 Sophos has announced that they has identified compatibility issues between PureMessage for Microsoft Exchange and Windows Server 2016 Datacenter.
At this point in time there are no plans to resolve these compatibility issues and Sophos therefore suggests running the product on one of the other certified Server platforms.
Sophos has updated the System Requirements documentation to reflect this incompatibility and apologizes for this inconvenience.

We have opened a support case asking why it is not stated what the compability issues are and what will not be working if installed on Datacenter-edition.
Could you please explain what will not work, if PureMessage 4.0.4 is installed on Windows Server 2016 Datacenter-edition?

Their answer was: The compatibility issues had to be severe enough for us to advise against the usage of this edition of Server OS, details of which have not been put on the KBA for various reasons.

And then they just refer to this article KBA 131992.

My question is: Has anyone tried to install PureMessage 4.0.4 with Exchange 2016 on Windows Server 2016 Datacenter-edition? And if yes, what issues did you experience?

Thanks alot!

Regards,

Bent

  • Is it just 2016 datacentre edition or all windows server 2016 versions? We've had grief with ours for ages but were told no one else was having the same problem.

     

    Did you get a response about what wouldn't work?

    regards

    andrew

  • In reply to pez:

    Hi,

    Sorry for the late reply.

    I got this reply from Sophos Support:

    "In testing we had seen instances on Server 2016 Datacenter where the PureMessage service was constantly starting and stopping when store scanning was enabled on the OS this has the potential to affect mailflow on exchange server. Hence it was consider to be incompatible.

    Recent testing does seem to indicate things actually work with Windows Server 2016 Datacenter OS and engineering Team believe the issues seen were actually caused by an older version of SAV.

    currently we are in discussion within teams about this issue. Once it is officially approved with FIX we will update the KBA to remove the incompatibility with Windows Server 2016 Datacenter. Until then Puremessage 4.0.4 will be consider to be incompatible with OS"

     

    As we won't be using Store scanning, it is not an issue for us.

    Hope this helps you.

    Regards,

    Bent

  • In reply to Bent Appeldahl:

    thanks for replying Bent,

     

    we do use store scanning and I've just installed 4.0.4 in the hope that it would fix the problems we were having. It looks like it has. For well over 12 months we've had problems with this, exactly this problem:

    "In testing we had seen instances on Server 2016 Datacenter where the PureMessage service was constantly starting and stopping when store scanning was enabled on the OS this has the potential to affect mailflow on exchange server."

    The release notes for 4.0.4 also specifically mention this. Fingers crossed it will be stable now. Thanks again for passing that on.

    regards

    andrew