Deploying Outlook e-mail configuration

We want to roll out the Outlook app to our users with the email profiles preconfigured.

Our policy file contains the Exchange Account setting which correctly configures the built-in Mail app. 
The exchange account is not used by the Outlook app, however. 

I tried to configure the Outlook by going to Apps->iOS->Outlook->Settings->Managed configuration and specifying the app parameters listed here: https://docs.microsoft.com/en-us/Exchange/clients/outlook-for-ios-and-android/account-setup?redirectedfrom=MSDN&view=exchserver-2019#key-value-pairs 
I used the %_EMAILADDRESS_% and %_USERNAME_% placeholders.

After saving the settings, I pushed the app to a test device. When opening the app after the reinstall, it still prompts me to create a new profile.

Apparently the configuration does not have any effect. Why is this?
Is there another way to configure the Outlook app using Sophos Central Mobile for iOS?

  • I use the following parameters with SMC on prem version:

     

    Normal behavior was, after opening the app it prompts to add the account. Of course you have to type in the password. This worked some month ago for sure.
    Just tested this today again and can confirm, that I only got a message that data is deleted.

    Maybe Microsoft changed something in last month. But what?

    PS Sorry for bad formatting, it’s difficult on an touchscreen.

    /Edited/

    Best regards 

    Alex 

  • In reply to Alexander Busch:

    This article states that com.microsoft.outlook.EmailProfile.AccountType must be set to BasicAuth while this one states that it must be ModernAuth. 
    Neither works for me.

    Additionally, pushing the app to a device shows the task as "An MDM command could not be executed -45 Completely failed" even though it installs successfully. Maybe the installation process recognizes that some of the configured paramters are wrong/not allowed? I can't find any more detailed information about what exactly caused the -45 error.

  • In reply to Lukas Rabe:

    Hi  

    Could you please confirm which SMC server version you are currently running or are you using Sophos Central? 

  • In reply to Shweta:

    Hi Shweta, 

     

    I am using Sophos Central.

  • In reply to Shweta:

    Hi ,

    any update on this?

  • In reply to Lukas Rabe:

    Hi  

    Apologies for the delay, I will discuss this issue with our escalation team and shall let you know the next course of action. 

  • In reply to Shweta:

    Hi  

    Could you please confirm the below details. 

    1) Does the app installation of a different app without managed settings work?
    2) Does the outlook app installation work without the managed settings?
     
     
  • In reply to Shweta:

    Hi Shweta, 

     

    I can confirm both details. 

    1) We have installed many different managed apps without configuration, e.g. Toggl
    2) Outlook app installation always works. It just never uses the managed settings.

     

    Kind regards
    Lukas

     

  • In reply to Lukas Rabe:

    Hi  

    I have checked this with our team, an in-depth investigation is required for this issue. I would recommend you to open a support case and PM me the case details.  

  • Answer from Sophos support (translated):

    It's not possible to transmit parameters to third party apps like Outlook. The managed configuration only applies to the "per-app VPN" feature.

    This is quite disappointing.

  • In reply to Lukas Rabe:

    Hi  

    Sorry to hear that. You can raise a feature request here.

  • In reply to Lukas Rabe:

    Sorry, but I believe this is wrong.

    I do pass configuration parameters to another app, that is working. And why is Sophos a member of the AppConfig group?

    https://www.appconfig.org/members/

    Why should these parameters only work with Android devices? There they are working. 
    I
    f that is true I think we will have a deeper look at some other products when our renewal is needed.

    Best regards 

    Alex