Sophos DEP profile - Skip Configuration not applying

Our Original DEP Profile had 'User can Skip MDM Profile Assignment' Unticked.
I now need to enable this, I have ticked the box and clicked Applied, i have confirmed that the devices is in the right Device Group and is getting the same DEP profile.
but when the device turns on, it doesn't give me an option to skip configuration.
A brand New device ( turned on after setting the 'User can Skip MDM Profile Assignment') gives me the option to Skip configuration.

I have turned off an on the device multiple times
I have erased all content and settings after signing in at the DEP part.
used Apple configurator to restore the device
I have made a new DEP profile and assigned it to the device and reset it.

Is there a trick to get devices to get updated DEP profiles settings. Seems like once it reads one profile it sticks to those settings.
is there a reason why it would overwrite the setting?

 

Is there anything else i can try to force new settings?

  • Hi  

    I have checked this with our support team and the only way to push the updated DEP profile is to factory reset the device to force the new settings. DEP profile is applied during the setup of the device. There is no immediate action performed if the DEP profile is changed. The new profile will be applied as soon as the device is activated again after a factory reset.

  • In reply to Shweta:

    Shweta

    Hi  

    I have checked this with our support team and the only way to push the updated DEP profile is to factory reset the device to force the new settings. DEP profile is applied during the setup of the device. There is no immediate action performed if the DEP profile is changed. The new profile will be applied as soon as the device is activated again after a factory reset.

     

     

    Hi Shweta
    Thanks for getting back to me
    As mentioned, i have factory reset the device multiple times. Even used apple configurator to restore / wipe the device but still its forcing me to apple DEP and sign in. 
    Can the support team mention what i need to confirm that its getting the correct DEP Profile?
    Kind regards
    Pete
     

  • In reply to Peter Caldwell:

    Hi  

    Could you please check under the device list and click on Synchronize with Apple DEP portal. Kindly check this link and see if it helps. If you still face the issue, I would recommend you to open a support case and PM me the case details.