Being asked for password after update to Sophos Mobile 7.1.2457

I was automatically upgraded to Sophos Mobile 7.1.2457 (18) earlier today and suddenly I can't get into my Android phone settings.  I get a prompt: 'Unlock app'.  I don't have App Protection turned on and I've never seen this before.  I did find a password in my pw list for 'Sophos App Application' but I've never been asked for it before.  And even if I now enter it, it gets rejected as 'Incorrect password'.  Has any one else seen this?  Phone is LG G4.

  • Same here. I use a LG G4 H818P DualSim / Android 6.0.1

    First I entered a pin in sophos app protection, to be able to get access to system settings.

    Next I disabled "access usage data" for "Sophos Mobile Security" in the security section of adroid,

    for getting access to my mobile, without everytime entering a pin/pwd.

    The problem persist since mid of last week (Week 40/2017)


    On my LG G5 running android 7, there is no such problem.


    Perhaps someone from Sophos Support engeneers reads this issue...



  • I have the same problem as stated by Peter Narramore. Phone is also a LG G4. At the moment I can't enter the Android settings. I have never set a App Protection password. I hope you can help me! On my other Phone Motorola Moto G4 Plus no such problem exists with Sophos

  • In reply to Martin Heinold:

    There has now been some follow-up from Sophos Technical Support: 'We have already found the cause ... will provide an update as soon as possible'.

    In the meantime, from user responses I've seen so far, there are a couple of options to stay secure until the fixed version is published.

    (a) Live with it for the moment.  Depends on how much you change settings.  Irritating, but your phone remains secure.

    (b) Try the following: 'enable App Protection then choose a password then I could access my settings for my cell'.  Posted by a reviewer on the Play Store*.  I haven't tried doing this, so no promises.

    Ultimately though, I'm not planning to switch to an alternative security app.  It's a free product with lots of features and no adverts etc.  I've used it 3 or 4 years on two different phones and this is the first problem I've had.

    If you're really desperate then you could temporarily uninstall until the fix is published.  But you then have no security, so I wouldn't recommend it.  And you would first need to disable admin rights for Sophos Mobile Security.  And that would entail installing and working out how to use some third party app which can do this.


    * See:

  • I have the same problem on an LG G4. I can still get into settings in the dock menu.

  • In reply to Jo Eltzeroth:

    Sophos Mobile Security version 7.1.2475 released 23rd October has cured this problem for me.

    - Peter