Home-Button funktioniert nicht im Kiosk-Modus


wir haben aktuell ein ziemlich kurioses Phaenomen: Wir nutzen in einem unserer Projekte Geraete der Typen Samsung Galaxy Active Tab 2 sowie Samsung XCover 4s und betreiben diese im Kiosk-Modus. Das Tab Active 2 funktioniert ohne Probleme, aber beim XCover 4s funktioniert im Kiosk-Modus der Home-Button nicht mehr. Ausserhalb des Kiosk-Modus funktioniert er wunderbar, im Kiosk-Modus macht er gar nichts. Das ist auf allen Geraet des Typs jederzeit reproduzierbar.

Diese Probleme treten bisher nur mit den XCover 4s auf, auf ebenfalls getesteten Geraeten wie einem Galaxy S8, einem Galaxy S10, einem Tab S5e oder einem Nokia 7.2 gibt es diese Probleme nicht.

Gibt es etwas, dass ich fuer den Kiosk-Modus freischalten kann, damit der Home-Button auch auf dem XCover 4s funktioniert? Oder gibt es sonst eine Moeglichkeit, den Button im Kiosk-Modus funktionsfaehig zu bekommen?

Unsere Sophos Mobile Server-Version: 9.6.2 (rev 20562)

Andreas Siebert.

  • Hi  

    To set the device into a true kiosk mode, you must clear at least the Allow Home button and Allow task manager checkboxes. Kindly check this article and see if it helps. 

  • In reply to Shweta:

    Hi :)

    Thanks for your reply, but I think, i does not fit here. We do not use the 'real' Kiosk-Mode where just one App is running, we use the Kiosk-Mode as Android Enterprise Device Owner with an app-group to allow a handful of apps, so the Home-Button would be used regularly. As mentioned: Up to date we figured just this one device-type with this strange kind of problem. Unfortanately this is (next to the Active Tab 2) one of the two device types we use in this project and we need the kiosk-mode on These devices.

    With Kind regards,
    Andreas Siebert.

  • In reply to Andreas Siebert:


    I have checked this with my team, I would suggest you raise a support case for this issue as it would require in-depth troubleshooting. Please PM me the case number once done. 

  • In reply to Shweta:

    Question can be considered closed, it is not the device, it seems to be the Android-version. On an older (not updated) XCover 4s with Android 9 everything worked fine, also in kiosk-mode, after the update to Android 10 it did not work anymore. Same with an S10: With Android 9 everything worked fine, after the update the navbar in kiosk-mode only showed the 'back-button', so kind of the same problem.

  • Kiosk mode is an advanced security feature which lets the IT Administrator lock down managed devices to run mystarbucksvisit a specific app or a set of preselected apps. Kiosk mode ensures users cannot modify device settings, access other features or apps present in the device, besides the one(s) whitelisted by the IT Administrator Mystarbucksvisit.