Android Enterprise Authentication on App Store not working

I am having problems getting my corporate Cat S41 devices setup in Android Enterprise mode. At first it would not accept afw#sophos at all, used a google account but that left the devices in Legacy Device mode. 

After a factory reset it will now allow the use of afw#sophos during the initial setup of the device. It will allow the Mobile Control app to be installed and update the system apps on the device. But that's it. No other apps that are on our mandatory apps list. I can't download apps from the managed play store as it keeps asking to sign in with a google account. 

Pushing the app from Central "fails completely". 

I tried the re-authenticating with play store button in the Control app. I tried with clearing Play Store cache and even with clear data. Tried again after factory reset but still no change. 

Android is version 8.0.













  • Hi  

    Would you please suggest whether you are using google account to access the managed play store or not. As you have mentioned above " it is keep asking to sign in with a google account."

    You can download the apk of the respective applications and upload them on the Sophos mobile console and push the policy which may install the application on the device.

  • In reply to Jasmin:

    Hi Jasmin,

    The device was setup during initial setup with afw#sophos to get it into Enterprise Mode. So the device does not have a google account!

    For Enterprise Management mode you do not require a google account on the device. The Sophos Mobile Control APP should handle the authentication to the managed play store to download the company allowed apps. Problem is it doesn't and as a result the Play Store will ask for a google account. afw#sophos or afw#setup won't work. I have not used a google account on the device.

    Regarding your workaround, The point of a managed play store with Enterprise mode is that it should work. In theory that is. In practise it doesn't. I saw other post advising to clear the cache, clear the data, still the button in the Mobile Control app to re-authenticate with Play Store does not work.

    You recommended Enterprise mode as a way to push apps without user intervention and for solving the Intercept X APP not being managed as it did not enroll automatically in Legacy device mode and requires the user's action to start and allow installation of the app.

    In Mobile Setup the Sophos APP source is set to Google Play Store not to hosted APK. I am starting to feel I get the runaround. 

    Are their know issues with App Store that we should know about? Will Intercept X be automatically enrolled and managed when pushed from the APK hosted store? 
















  • In reply to Fred Blum:

    Has there been any solution related to your issue?  Iam having the same problem :(

  • In reply to CraigKaminski:

    Yesterday evening I did a factory reset again, installed Mobile Control with afw#sophos and enrolled the mobile control app. This time the Managed Play Store will open any time I open Play Store without asking for a signin. I will check at work again today to see if it has anything to do with the WIFI network at work (sophos). Only problem I still have is that Intercept X does not enroll automatically when Mobile Control is installed. It still reports the device as non complaint as a initial scan is overdue and a sync required.
  • In reply to Fred Blum:


    There are no issues reported with App store at this time. If you’ve selected the Android Enterprise mode, you must set up Android Enterprise for your organization before you can enroll devices, would you please provide the screenshot of the task view while you try to install app? Please check this article for more information. 

  • In reply to Shweta:

    Yesterday April 28th during working hours (UTC+2) I could use afw#sophos to install the Sophos Mobile Control app and enroll it. Only afterwards Play Store would not connect to the managed play store and ask everytime for a google account to sign in. I have tried multiple times during the day, resetting to factory defaults and same procedure to no avail. 

    I tried April 28th in the evening working from home and this time the App Store would connect aftyer enrolling normally to the managed play store. So I thought it might have something to do with the firewall at work. 

    Tried again this morning at work, could connect to the managed play store, reset to factory default, same procedure and there are no issues with the app store anymore. 

    Yesterdayduring the day  I have tried multiple times same procedure but it would not connect.  Play store seems fixed now. 



  • In reply to Fred Blum:


    That is strange, as you stated it might be due to the network issue. However glad to know that it is fixed for you now.