Sophos Accessibility Service on Huawei P20 Pro

I have the Huawei P20 Pro running the latest Sophos Mobile Security however it seems to have a problem with the Accessibility Service keeps turning itself OFF. This appears to happen on a restart, however I've only ever restarted it a couple of times since getting the device just over a month ago but it also seems to happen at other times too. I can't be sure of when that happens at the moment as I usually only notice when apps are updated and I spot that the Sophos scan isn't happening.

I have seen that others have reported this with other Huawei devices running Oreo.

I tried to raise a ticket with support but because I'm only using the free version I only got redirected to this forum.

Any ideas anyone?


  • Hi Ian Dobson,

    Searching for issues with Accessibility service and Huawei P20, I came across few forums mentioning that it might be due to battery saver settings. Can you make sure the Sophos Mobile Security application is not optimized under battery settings?

    Having said that, Let's see if there are any logs entries related to this in the app. Can you navigate to the below-mentioned option and share me the logs. I will have a quick look at it and see if we can find anything anonymous. 

    Sophos Mobile Security > Menu (Top left corner) > Settings > Send Trace log- you can either save it in the cloud drives or sent it via email. 

  • In reply to Gowtham Mani:

    Hi, I tried the email route but got told that as I'm using the free version I can't get support! Not terribly useful when it seems like a fundamental problem.

    Has there been any progress made with this issue because it seems like quite a few people experience the same thing.

    It still happens BTW.


  • In reply to Gowtham Mani:


    This is still an issue, is this a problem with Huawei devices?

    I have recently subscribed to Sophos Home Premium, does that give me support for Sophos Mobile now? Previously your request to email logs was met with a blank because I didn't have a paid version.

    Every now and again I have to manually turn the accessibility service back on. Do you think it could be happening every time the App is updated? It could be that.


  • In reply to Ian Dobson:


    I believe this is an issue with Huawei devices. I have installed the application in my test Android phone (Moto G5) and have not faced this issue once. Also, Sophos Home premium entitles you for support of Sophos Home for Windows and Mac only.