Updating apps on a Supervised iPad through Sophos Mobile Control



I am trying to update a number of apps on our fleet of iPads, however the install always bombs out with the error

Apr 27, 2020, 2:30 PM An MDM command could not be executed. -45 Completely failed

The main app i am trying to update is the Sophos Mobile Control. So far I have tried restarting the iPads, turning them off for 5 minutes, and also have force restarted them. There is also no other pending tasks in the task list.

The iPad's are supervised and are running PadOS 13.4.1

Any ideas on how to fix this issue?


Thanks in advance

  • Hi  

    Could you please review the device profile settings that are applicable only for a supervised iOS device, please check this link for the settings which are available that will be indicated in blue label in Sophos Mobile admin. 

  • In reply to Shweta:

    Hi Shweta,

    Thank you for this information, unfortunately it did not fix my issue. Since logging my question, I have been able to update about half of the iPads successfully but there was a weird process. To update these ones, this is the process I had to follow.

    • Have the Sophos Mobile Control App open on the iPad and set off the task through the Sophos console.
    • A pop-up will then appear on the iPad asking if I would like to update Sophos Mobile Control, hit update.
    • A few seconds later another pop-up will appear saying "The app 'Sophos Mobile Control' could not be updated." Dismiss this pop-up
    • Then I have to close the app and restart it
    • Wait for the Task to finish in the Console, it will say the task is successful (even though it failed).
    • I then set the install task off again through the Sophos Console
    • The update pop-up appears again, and i agree to the update.
    • The App will close itself and update without any issues.
    • The task will then finish and say it is successful (it is actually successful this time).

    However if the app does NOT update on the second go (i.e. receive the "The app 'Sophos Mobile Control' could not be updated." message), the app will not update at all no matter how many times you try. You just receive the "The app 'Sophos Mobile Control' could not be updated." message each time.

    Any suggestions to fix this issue?


  • In reply to Tim Hunt:


    That is strange as only half devices are facing this issue, I will check this with my team and shall get back to you. 

  • In reply to Shweta:


    Could you please confirm if you are using VPP? Also, if you can help me with the screenshot of the task view from the SMC server. 

  • In reply to Shweta:


    I just wanted to follow up with you on this thread, are you still facing the issue? 

  • In reply to Shweta:

    Yes and no, I ended up re-provisioning them as we had to provision new set of iPads to get around the issue. I haven't tried to update any apps as they are now on the latest versions. I will let you know if i run into this issue when updating apps in the future.




  • In reply to Tim Hunt:

    Sure  please let us know when if you face the issue again.