SMC hangs when updating Google Playstore during initial install

I'm installing a Samsung Galaxy A3. During installation SMC hangs at the point where Google Playstore is updated. It shows 45% for several hours now. I can press the back button but then SMC asks me if I want to reset the phone. I did this and started again but it hangs at the same point. Didn't have this issue with the last 15 devices. Any idea? Temporary problem with Google Playstore / Android for Work? Or maybe device problem? It worked fine before.

  • I just realized that SMC was updated on 29. August to 9.0.3471. Maybe there is a bug in the new version (again)?

  • In reply to Jelle:


    Did you manage to get a solution to this? I am having the same issue.


  • In reply to Dave Chunilal:

    Yes, it worked at a certain point. I'm currently not sure what was the solution. Android 7.0 was installed and I think I installed an update before trying again (but still was Android 7 after that). Second possibility is that it worked without changes later on when trying again and again. So it could have been a temporary issue with Google or Sophos.

    From my experience I would say that it is a temporary issue if you have Android 8.0 or later installed. Android 6 and 7 seem to produce issues with SMC.

  • In reply to Jelle:

    Hi Jelle,

    Thanks for this. I have it on Android 6 right now and been having this issue for a few days. So i'll try and update Android and see if that helps.

    Dave S. Chunilal