Android Enterprise - Play Store issue [DF-DFERH-01]

Hello,

 

since a few days i got following issue using Google Play on Android Enterprise (Device Owner).

 

Apps on the first page "Enterprise" are showed correctly but when i try to switch to another page e.g. "Business", play store shows "Error [DF-DFERH-01]".

This happens not to all devices, but on most of them. Every app from the other pages can be found and installed when searching in play store for them.

 

Of course i've tried to ask uncle google but those solutions didn't work for my problem. I've wiped the Cache of Google Play and Google Play Services, uninstalled all of the updates and tried to auth again via Control-App.

 

Is there a maximum amount of devices i can use with one Managed-Google-Play-Account? (currently ~200).

 

Does anyone else have the same issue or a solution for it?

  • Hi  

    Could you please confirm on which devices you are facing the issue? Could you please confirm if you are using the latest version of the SMC client for Android?

  • In reply to Shweta:

    Current device is a Galaxy S9 - SM-G960F with Android 9.

    It has the latest version of Control-App installed (9.0.3446)

     

    Google Play-Store Version: 16.1.23

    Google Play-Services Version: 18.3.85

  • In reply to hellm00d:

    Hi  

    Thank you for confirming. This would require in-depth investigation along with certain logs. Request you to please create a support case along with these logs attached. Kindly PM me the case details. 

  • In reply to Shweta:

    We've got the same problem here. Been with tech support for a large number of days now.

     

    My personal thought, based on our issues (which is  basically the same as yours?) is if the resetting of the Google App on your handsets don't work, I think I've found that an App in hour Google Play/Work approved list has now been removed from Google Play. But when I look at the list of apps in Sophos Central, it's listing 1 app with "unavailable". So now I have the problem that Sophos Central is showing it, yet I can't removed it from the approved list! So this could be a backend problem with Google?

  • In reply to Shweta:

    Hi,

    We are also having this problem, using Samsung A20e.  Work profile shows this error when opening the Play store, but you are still able to search published apps. 

    Thanks,

  • In reply to SFIA_IT:

    Hi  

    Can you please PM me the support ticket number so that I can look into it for you? 

  • In reply to Jo Wilson:

    Hi  

    I would recommend you to open a support ticket to resolve this issue at the earliest. Once you have opened the ticket, please PM me the support ticket number.

  • In reply to Yashraj:

    Hi,

    Our ticket number is [#9025426], though the outcome seems to be "it's google, nothing we can do about it" (I'm paraphrasing, my latest responses don't actually say this word for word).

  • Good morning everybody,

     

    last friday i received an e-mail in which i was told that the global escalation support is analyzing the issue.

     

    Since Monday i can use Play-Store on my devices in a normal way - as far as i can say. I tried on 5 devices on which the issue occured before.

     

    New registered devices also doesn't have the issue.

     

    Can anyone confirm that?