Policies don't work anymore when adding a device

After the last Sophos Mobile Control update policies don't seem to be transferred anymore. Before the update policies for wifi, password strength and email were set when adding a new device. After the update the wifi is not connected and I have to add it manually. Email accounts and settings are not preloaded and the password strength is at basic setting.

This is currently a big problem, especially the password strength. Re-transferring the policies doesn't help.

Does anybody have the same issues?

  • Hi  

    May I ask which version you are currently on? Also, a bit more information if any specific devices are facing this issue? Assigned policies are updated on the device each time a device connects to the Sophos Mobile server. If you add it manually, is synchronization successful?

  • In reply to Shweta:

    Hi ,


    we use Sophos Central with Mobile Control Advanced. Sophos Mobile Control app is version 9.0.3446.

    I see this behaviour on Samsung Galaxy A3 (Android 8.0) and Galaxy XCover 4 (Android 8.0, 8.1, 9.0) devices. Both worked before the last update of the app.

    Policies are not transfered or executed during initial setup and also not when assigning the policies with a seperate work package. Synchronization is shown as successful inside the app and in Sophos Central but in fact it is not.

  • In reply to Jelle:

    Hi ,

    now this is strange. The last two devices (one Galaxy A3 and one Galaxy XCover 4) worked without issues. Could it be it was a temporary issue with Sophos Central?

  • We're having the same problem an on premise SMC server version 7.0.8 (rev 9453). Worked fine with App version 9.0.3445, but not with App version 9.0.3446.

  • similar issue with installing a profile to any device. Any help would be appreciated. thanks


    Initially it says "Will be retried" and then after a minute it ends up with status " Completely Failed"

    Last successful device i did on 26/7/2019... i am trying from last few days butno luck.


    I am using SMC in premises  version 7.0.8 (rev 9453)

    Device: Samsung version 9.0.3446

  • In reply to Faisal Khan:

    We didn't have any error messages. From Sophos Central everything seemed ok but the policies weren't there on the devices or at least not active.

  • I've just had this brought to my attention this morning:
    Google Cloud Messaging services withdrawal - likely to be the cause of our problem.
    If you have any old Apple kit, consider how far you upgrade:
    8.6 - Sophos Mobile switches from Google Cloud Messaging (GCM) based push messaging to the new Firebase Cloud Messaging (FCM) push messaging.
    9.0 - Removed support for iOS 9.3.x and 10.x
  • In reply to Paul Wright:

    Not sure if this is the reason

    - issue on Android, not with iOS

    - Android version 8 or higher

    - latest Sophos Mobile Control

    - running on Sophos Central

  • In reply to Jelle:

    Happened again today on a Samsung Galaxy A3 with Android 8.0. Worked on another A3 with Android 8 about 3 weeks ago. This is really strange as each device was factory reset before.

  • In reply to Jelle:

    This seems to be a random issue. Worked on another Samsung Galaxy A3 yesterday but failed on 2 Samsung Galaxy XCover 4. As mentioned I have to do a lot of thing manually which normally should happen through the policies.

  • In reply to Jelle:

    The issue remains even with the latest version of SMC released on 29th August. Sometimes it works, sometimes I have to do a lot of things manually.