ColorOS

I installed Sophos in my RealMe mobile phone with ColorOS 6. Whenever I unlocked my phone it always ask me to allow the Sophos app to run in background causing the battery to drain faster. I click allow then stay protected. After a while the phone is idle then I unlock it again, then it ask me again.need your assistance on how I will stay protected.

Thank you.

  • Hi  

    Would you please suggest the version of the Sophos Mobile you are running? Kindly take a look at this thread as well, where the same issue was discussed, see if it helps. 

  • Hi,

    Android has become somewhat idiotic with the latest versions in terms of running applications in the background. Please try the following:

    1. From the home screen of your Android device, head over to the Settings and scroll down to access the “Battery” entry.
    2. Click on "Battery Optimization"
    3. Find the Sophos Intercept X for Mobile application and click on it
    4. Select "Don't optimize"

    The application now should be allowed to run in the background.