installation failed could not uninstall existing sophos software

I try to install Sophos endpoint but I have this issue
I had a program in my laptop and I deleted but when I search in registry file I found some file related to Sophos


  • Hi  

    I'd suggest you to log a case with Sophos support here as they'll help you to uninstall the Sophos product completely and will help you to install on your machine.

    Once the case has been logged, Please PM me the case details.

  • Hi  

    Could you please run below command and see what are the components that are still being installed on the machine. 

    REG QUERY HKLM\Software\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall /s /f SOPHOS 

    Once done, kindly take a registry backup before making any changes in the registry. Kindly check on the below location if there are any remnants of the older Sophos version installed. 


    Let me know how this goes. 

  • In reply to Shweta:

    that what appears 

    yes there is some file in registry, but I didn't delete it

  • In reply to Hanan Al Mutairi:


    Thank you for providing the screenshot. Could you please try the steps listed in this article and see if you are able to uninstall Sophos completely, it has all the registries that are listed in the above command. Let me know how it goes. 

  • In reply to Shweta:

    actually I try to apply this command
    but when i write this two command "C:\Program Files\Sophos\Sophos Endpoint Agent\uninstall cli.exe" or "C:\Program Files (x86)\Sophos\Management Communications System\Endpoint\Uninstall.exe"
    to enter to folder Sophos Endpoint Agent this message appears folder not found
     I don't know if I wrote command in the wrong way or not please check that for me "I write the command like this cd \Program Files\Sophos\Sophos Endpoint Agent\uninstall cli.exe"
  • In reply to Hanan Al Mutairi:


    Could you please check under C:\Programfiles\ ,C:\Program Files(x86) and C:\Programdata if there are any Sophos Folders? Try to create the bat file as per the above article and run the same on the machine and see if it uninstalls all the remnants from an older version of Sophos installed. If you are still facing the issue, I would recommend creating a support case

  • I just had this issue and I am still trying to resolve it.  It started out after Sophos Central was installed, but not everything would run.  After trying to uninstall Sophos Central the installer failed to complete the uninstall.  A reboot did not help so I had to remove all Sophos Services and delete the Sophos folders in Program Files, Program Files (x86), and ProgramData.  Sophos Central then started to install, but would fail at the end leaving a partial install.

    I cleaned out the Registry of all Sophos content and tried again.  This time it was almost finished before the install failed yet again.  Since this PC had an On Prem Client of Sophos installed before Central, I tried to installed the Client from SEC, but it would not remove the Central Client.

    Right now I'm struggling to get either client installed.

  • In reply to Michael Ethier:


    Please use SophosZap removal tool as per the instructions, and try installing again.


  • In reply to DianneY:

    Wow!  Did that ever work nicely.  Took care of the whole issue.


    Thank you for the quick reply.

  • In reply to Michael Ethier:


    Glad to know it helped.