UTM 9.3+ Home installation on Intel D2500CCE not working

I run an Intel Atom D2500 Dual LAN, Dual COM Fanless Mini-ITX PC, D2500CCE, 2GB, T3410, which successfully run using "unetbootin-windows-608.exe" or "unetbootin-windows-608.exe" and buring the "asg-9.204-20.1.iso" on the USB stick (635MB in size).

In the past I have installed 9.204 and upgrade to 9.411 (last backup available) but installing 9.204 does not offer me to update to 9.4. That is the reason for starting from scratch with a Sophos UTM 9.5 release.

However "unetbootin-windows-655.exe" and buring the "ssi-9.503-4.iso" on the USB stick (830MB in size). is no longer working. I have tried "ssi-9.358-3.1.iso" and "ssi-9.414-2.1.iso" as well but these do also not allow the startup to be pause like the 9.2 version.


Any suggestion how to load a new version of UTM Home on the Intel D2500CCE ?

  • Hi,

    besides being in the wrong forum what NICs does it run. You are also trying to run the wrong version you should be using the software version not not the Sophos device version.


    I would ask a forum mod to move you to the correct forum.