The installation failed

I have tried several times to install the Sophos Anti-Virus Home Edition for Mac, and I keep receiving the following notification: "The installation failed. The software was not installed successfully. Remove the software and re-install."

I removed the software, re-installed, and received the same result. I see this has been an issue in the past, but I could not discern how to fix this issue from the other threads (some of the conversations were years old, so that might also be why I could not find a solution). I have repaired disk permissions, uninstalled a previous version I had installed on my laptop, yet I am still receiving this notification.

Any advice? Thanks in advance!

:1020811
  • Hi Jtash,

    Have you tried checking the install log to see if it gives any clues as to what might be failing? 

     

    To check that, you can try the following:

     

    1. Hold down command-spacebar (spotlight search)
    2. Type console and hit return
    1. On the left, navigate to Files > /private/var/log > install.log

     

    if you find the log too cluttered, you can always click the "clear display" button at the top, and then run the install again. Let us know what you find!

    :1020813
  • Hi Serranonymous,

    Thank you for your reply, and sorry for my delay - I thought I would receive an email notification once I rceived a reply.

    I followed your instructions on how to check the install log. When I check the "/private/var/log", nothing is displayed, but I am able to find the log under "All Messages".

    Please see below for the install log. I've bolded three instances where the response is "NO", and one instance where it states the installation is successful, although the notification from the installer states otherwise (please see screenshot below):

    5/8/15 8:12:33 AM InstallationDeployer[961] *** __NSAutoreleaseNoPool(): Object 0x1001122e0 of class NSCFString autoreleased with no pool in place - just leaking

    5/8/15 8:12:33 AM InstallationDeployer[961] *** __NSAutoreleaseNoPool(): Object 0x1001160d0 of class NSPathStore2 autoreleased with no pool in place - just leaking
    5/8/15 8:12:43 AM authexec[966] executing /Users/johntastepe/Downloads/savosx_he_r (1)/Sophos Anti-Virus Home Edition.app/Contents/MacOS/tools/InstallationDeployer
    5/8/15 8:12:44 AM Sophos Installer[966] [SMEInstallController.m:209] Installing he version 9.2.2
    5/8/15 8:12:45 AM Sophos Installer[966] [SMEInstallController.m:667] Upgrading the "he" product
    5/8/15 8:12:45 AM Sophos Installer[966] [SMEAggregateInstallStrategy.m:71] "installer.prepare.stopProcesses" success: YES
    5/8/15 8:12:45 AM Sophos Installer[966] [SMEAggregateInstallStrategy.m:71] "installer.prepare.removeComponents" success: YES
    5/8/15 8:12:45 AM Sophos Installer[966] [SMEAggregateInstallStrategy.m:71] "installer.prepare.removeKeychains" success: YES
    5/8/15 8:12:46 AM Sophos Installer[969] [SMEInstallController.m:221] Starting receipt service for he version 9.2.2
    5/8/15 8:12:47 AM Sophos Installer[969] [SMEReceiptServiceStrategy.m:194] Fix plan is empty. Nothing to fix
    5/8/15 8:12:47 AM Sophos Installer[966] [SMEBuildInstallPlanStrategy.m:189] Install plan:
    components: [data]
    daemons: []
    managed daemons: [com.sophos.intercheck, com.sophos.scan]
    agents: []
    5/8/15 8:12:47 AM Sophos Installer[966] [SMEAggregateInstallStrategy.m:71] "installer.localPayload.buildPlan" success: YES
    5/8/15 8:12:49 AM Sophos Installer[966] [SMEAggregateInstallStrategy.m:71] "installer.localPayload.cacheManifestComponents" success: YES
    5/8/15 8:12:49 AM Sophos Installer[969] [SMEProcessStopStrategy.m:190] Service Manager failed while stopping managed daemons (
    "com.sophos.intercheck",
    "com.sophos.scan"
    ).
    5/8/15 8:12:49 AM Sophos Installer[969] [SMEAggregateInstallStrategy.m:71] "receiptService.removeComponents.stopProcesses" success: YES
    5/8/15 8:12:49 AM Sophos Installer[969] [SMEAggregateInstallStrategy.m:71] "receiptService.removeComponents.removeFiles" success: YES
    5/8/15 8:12:49 AM Sophos Installer[969] [SMEReceiptServiceStrategy.m:254] "receiptService.removeComponents" success: YES
    5/8/15 8:12:49 AM Sophos Installer[966] [SMEAggregateInstallStrategy.m:71] "installer.localPayload.remoteRemove" success: YES
    5/8/15 8:12:50 AM Sophos Installer[966] [SMEAggregateInstallStrategy.m:71] "installer.localPayload.installComponents" success: YES
    5/8/15 8:12:50 AM Sophos Installer[966] [SMEProcessStartStrategy.m:273] Service Manager failed while evaluating managed daemons [com.sophos.intercheck, com.sophos.scan].
    5/8/15 8:12:50 AM Sophos Installer[966] [SMEAggregateInstallStrategy.m:71] "installer.localPayload.processStart" success: NO
    5/8/15 8:12:50 AM Sophos Installer[966] [SMEAggregateInstallStrategy.m:71] "installer.writeReceipt" success: NO
    5/8/15 8:12:50 AM Sophos Installer[966] [SMEInstallController.m:562] "installer" success: NO
    5/8/15 8:12:50 AM Sophos Installer[969] [SMEInstallController.m:562] "receiptService" success: YES
    5/8/15 8:12:50 AM [0x0-0x7c07c].com.sophos.macendpoint.InstallationDeployer[961] The installation was successful.
    5/8/15 8:12:51 AM Sophos Installer[966] [SMEInstallationStatusService.m:227] Internal error. The current state is an active state but the main thread has completed.

    Thanks in advance for your help,

    J

    :1020827
  • Hi again,

    Is anyone available/able to respond to my question above?

    Many thanks,

    John

    :1020850
  • Hi Team,

    I have tried several times to install the Sophos Anti-Virus Home Edition for Mac, and I keep receiving the following notification: "The installation failed. The software was not installed successfully. Remove the software and re-install."

    I removed the software, re-installed, and received the same result. I see this has been an issue in the past, but I could not discern how to fix this issue from the other threads (some of the conversations were years old, so that might also be why I could not find a solution). I have repaired disk permissions, uninstalled a previous version I had installed on my laptop, yet I am still receiving this notification.

    Install Log

     

    5/8/15 8:12:33 AM InstallationDeployer[961] *** __NSAutoreleaseNoPool(): Object 0x1001122e0 of class NSCFString autoreleased with no pool in place - just leaking

    5/8/15 8:12:33 AM InstallationDeployer[961] *** __NSAutoreleaseNoPool(): Object 0x1001160d0 of class NSPathStore2 autoreleased with no pool in place - just leaking
    5/8/15 8:12:43 AM authexec[966] executing /Users/johntastepe/Downloads/savosx_he_r (1)/Sophos Anti-Virus Home Edition.app/Contents/MacOS/tools/InstallationDeployer
    5/8/15 8:12:44 AM Sophos Installer[966] [SMEInstallController.m:209] Installing he version 9.2.2
    5/8/15 8:12:45 AM Sophos Installer[966] [SMEInstallController.m:667] Upgrading the "he" product
    5/8/15 8:12:45 AM Sophos Installer[966] [SMEAggregateInstallStrategy.m:71] "installer.prepare.stopProcesses" success: YES
    5/8/15 8:12:45 AM Sophos Installer[966] [SMEAggregateInstallStrategy.m:71] "installer.prepare.removeComponents" success: YES
    5/8/15 8:12:45 AM Sophos Installer[966] [SMEAggregateInstallStrategy.m:71] "installer.prepare.removeKeychains" success: YES
    5/8/15 8:12:46 AM Sophos Installer[969] [SMEInstallController.m:221] Starting receipt service for he version 9.2.2
    5/8/15 8:12:47 AM Sophos Installer[969] [SMEReceiptServiceStrategy.m:194] Fix plan is empty. Nothing to fix
    5/8/15 8:12:47 AM Sophos Installer[966] [SMEBuildInstallPlanStrategy.m:189] Install plan:
    components: [data]
    daemons: []
    managed daemons: [com.sophos.intercheck, com.sophos.scan]
    agents: []
    5/8/15 8:12:47 AM Sophos Installer[966] [SMEAggregateInstallStrategy.m:71] "installer.localPayload.buildPlan" success: YES
    5/8/15 8:12:49 AM Sophos Installer[966] [SMEAggregateInstallStrategy.m:71] "installer.localPayload.cacheManifestComponents" success: YES
    5/8/15 8:12:49 AM Sophos Installer[969] [SMEProcessStopStrategy.m:190] Service Manager failed while stopping managed daemons (
    "com.sophos.intercheck",
    "com.sophos.scan"
    ).
    5/8/15 8:12:49 AM Sophos Installer[969] [SMEAggregateInstallStrategy.m:71] "receiptService.removeComponents.stopProcesses" success: YES
    5/8/15 8:12:49 AM Sophos Installer[969] [SMEAggregateInstallStrategy.m:71] "receiptService.removeComponents.removeFiles" success: YES
    5/8/15 8:12:49 AM Sophos Installer[969] [SMEReceiptServiceStrategy.m:254] "receiptService.removeComponents" success: YES
    5/8/15 8:12:49 AM Sophos Installer[966] [SMEAggregateInstallStrategy.m:71] "installer.localPayload.remoteRemove" success: YES
    5/8/15 8:12:50 AM Sophos Installer[966] [SMEAggregateInstallStrategy.m:71] "installer.localPayload.installComponents" success: YES
    5/8/15 8:12:50 AM Sophos Installer[966] [SMEProcessStartStrategy.m:273] Service Manager failed while evaluating managed daemons [com.sophos.intercheck, com.sophos.scan].
    5/8/15 8:12:50 AM Sophos Installer[966] [SMEAggregateInstallStrategy.m:71] "installer.localPayload.processStart" success: NO
    5/8/15 8:12:50 AM Sophos Installer[966] [SMEAggregateInstallStrategy.m:71] "installer.writeReceipt" success: NO
    5/8/15 8:12:50 AM Sophos Installer[966] [SMEInstallController.m:562] "installer" success: NO
    5/8/15 8:12:50 AM Sophos Installer[969] [SMEInstallController.m:562] "receiptService" success: YES
    5/8/15 8:12:50 AM [0x0-0x7c07c].com.sophos.macendpoint.InstallationDeployer[961] The installation was successful.
    5/8/15 8:12:51 AM Sophos Installer[966] [SMEInstallationStatusService.m:227] Internal error. The current state is an active state but the main thread has completed.

    Any advice? Thanks in advance!

    J

    :1020858
  • Hi Jtash,

    Sorry about the slow reply. I was just re-reading your thread and noticed that you said you had a previous version of Sophos installed on this laptop. Curious if you can tell me which version you had, and how you uninstalled it? Did you uninstall using the Sophos Uninstaller App?

    This article gives some details on how to uninstall SAV - I think it would be a good idea to review this, and maybe download and run the appropriate removal tool before trying to reinstall again.

    If that doesn't work, you should try to remove SAV manually. First rrom Terminal try the following to see if anything is listed:

    ls /var/db/receipts/com.sophos.*

    Then, remove everything in the following list:
     
    /Library/Sophos Anti-Virus
    /Library/LaunchDaemos/com.sophos.*
    /Library/LaunchAgents/com.sophos.*
    /Library/Preferences/com.sophos.*
    /Library/Logs/Sophos Anti-Virus.log
    /Applications/Sophos Anti-Virus.app
    /Applications/Sophos Remove.app
    /var/db/receipts/com.sophos.*
     
    Note: You will need administrative rights to remove most of those files. Then reboot, to ensure everything is cleared from memory too. Then run through the list again, to ensure you got everything.
     
    Warning: Be cautious when deleting things in some of those directories. Not everything in there is related to our software - our files contain the name "Sophos".

    I hope that helps!

    :1020862
  • Hi serranonymous,

    It seems that I had version 4.97.0 installed from around 2011. I did not have the Sophos Uninstaller App, so I just deleted it from my applications folder. Is that equally effective, or should I have used an uninstaller? I tried using the uninstallers from the page you linked to, but when using those, I receive the notification that "Sophos Anit-Virus is not intalled."

    I also went into my Terminal using [ls /var/db/receipts/com.sophos.*] to remove SAV manually, but none of the options you listed are present; only the following:

    /var/db/receipts/com.sophos.cmplugin.8.0.1.installer.bom
    /var/db/receipts/com.sophos.cmplugin.8.0.1.installer.plist
    /var/db/receipts/com.sophos.sau.cli.8.0.1.installer.bom
    /var/db/receipts/com.sophos.sau.cli.8.0.1.installer.plist
    /var/db/receipts/com.sophos.sau.srv.8.0.25.installer.bom
    /var/db/receipts/com.sophos.sau.srv.8.0.25.installer.plist
    /var/db/receipts/com.sophos.sav.cli.4.97.0.installer.bom
    /var/db/receipts/com.sophos.sav.cli.4.97.0.installer.plist
    /var/db/receipts/com.sophos.sav.data.8.0.installer.bom
    /var/db/receipts/com.sophos.sav.data.8.0.installer.plist
    /var/db/receipts/com.sophos.sav.gui.8.0.25.installer.bom
    /var/db/receipts/com.sophos.sav.gui.8.0.25.installer.plist
    /var/db/receipts/com.sophos.sav.ic.8.0.14.installer.bom
    /var/db/receipts/com.sophos.sav.ic.8.0.14.installer.plist
    /var/db/receipts/com.sophos.sav.removal.8.0.1.installer.bom
    /var/db/receipts/com.sophos.sav.removal.8.0.1.installer.plist
    /var/db/receipts/com.sophos.sav.savi.4.97.0.installer.bom
    /var/db/receipts/com.sophos.sav.savi.4.97.0.installer.plist
    /var/db/receipts/com.sophos.sav.srv.8.0.8.1.installer.bom
    /var/db/receipts/com.sophos.sav.srv.8.0.8.1.installer.plist
    /var/db/receipts/com.sophos.sav.sumscankit.8.0.8.1.installer.bom
    /var/db/receipts/com.sophos.sav.sumscankit.8.0.8.1.installer.plist
    /var/db/receipts/com.sophos.security.7.2.0.installer.bom
    /var/db/receipts/com.sophos.security.7.2.0.installer.plist
    /var/db/receipts/com.sophos.ui.8.0.25.installer.bom
    /var/db/receipts/com.sophos.ui.8.0.25.installer.plist

    Thank you for your continued help. I can't seem to find the issue.

    J

    :1020881
  • I'd suggesting manually removing the software, rebooting, and then trying a reinstall - make sure you reboot in between,

    1. Open Terminal from Spotlight.

    2. Type in the following commands:
      sudo pkill -9 “Sophos*”
      sudo rm -r /Library/Sophos\ Anti-Virus
      sudo rm -r /Library/LaunchDaemos/com.sophos.*
      sudo rm -r /Library/LaunchAgents/com.sophos.*
      sudo rm -r /Library/Preferences/com.sophos.*
      sudo rm -r /Library/Logs/Sophos\ Anti-Virus.log
      sudo rm -r ~/Library/Logs/Sophos\ Anti-Virus/Scans/
      sudo rm -r /Applications/Sophos\ Anti-Virus.app
      sudo rm -r /Applications/Remove\ Sophos\ Anti-Virus.app/
      sudo rm -r /var/db/receipts/com.sophos.*
      sudo rm -r /Library/Extensions/Sophos*
      Note down/copy any error messages that appear.  'File not found' or 'no such directory' is OK but errors, failures, and 'cannot...' etc. are interesting to the problem.

    3. Reboot the computer.  Properly reboot the computer and not just a log off.
    4. Attempt to reinstall.
    :1020884
  • I know this thread is 2 years ago, and you might not need this reply anymore, but for people who struggled to find an answer to this same issue like me, and maybe tech dumb like me, can find an easy solution to this. I have this same issue and this is what helped me:

    "I found a easy way to get the installer to work. Right click "Sophos Installer.app" click on Show Package Contents go to the "MacOS" folder run the installer in that folder.

    Work around for now."

     

    That's how i managed to install Sophos after almost 1 hour struggling and almost giving up! Here's a screenshot to the hero reply:

  • In reply to Van Nguyen Le:

    As indicated by AndrewGreening, sometimes installing through the GUI from "Sophos Installer.app" also fails and as a result, this work around worked for me. 

    Right Click on Sophos Installer (Show Package Contents) ---> Contents Folder --> MacOS Folder and right click on the installer file to open with terminal. Works like a charm so far when I have encountered error through the GUI. 

  • In reply to Eagle Eyes:

    Hello. I have just purchased this software and am having the exact same issue. I have performed all the suggestions outlined in the responses, even the last one that involves this workaround and opening with the terminal. All have failed. Does anyone have any other suggestions? From what it looks like this has been an ongoing issue for some time and I find it hard to believe that this has not been dealt with by Sophos. 

  • In reply to Graham C:

    Having the same exact issue and tried all the previously suggested solutions with no positive results. Any more suggestions to a fix would be welcome.