How to satisfy a recurrent 'Security and Privacy' pop-up?

Hello,

I'm a new member. Joined because I've been clicking ignore for too long on an annoying pop-up and am hoping to actually solve it now. The pop-up states:

 

Sophos Endpoint

You need to change your 'Security & Privacy' settings in order to protect this computer.

Click 'Open Security & Privacy' and then click 'Allow' within the next screen.

 

In theory the next step is easy ... except there is no "Allow" option at the next screen. And so I am left with no choice but to repetitively hit "Close" to ignore the pop-up. I run 10.13.6 (High Sierra) on a 2018 MBPro, in case that helps anyone lead me to an alternative solution.

Thank you in advance for your time and attention.

~Dave 

  • Hi all,

    Try the following on your Mac to see if the issue still occurs:

    1. Restart your Mac
    2. Before OS X starts up, hold down Command-R and keep it held down until you see an Apple icon and a progress bar. Release. This boots you into Recovery
    3. From the Utilities menu, select Terminal
    4. At the prompt type exactly the following and then press Return: csrutil disable
    5. Terminal should display a message that SIP was disabled
    6. From the  menu, select Restart.
    7. Open Security & Privacy in the Apple System Preferences window
    8. Sophos should now show up near the bottom of the window.  Click Allow
    9. Restart your Mac
    10. Before OS X starts up, hold down Command-R and keep it held down until you see an Apple icon and a progress bar. Release. This boots you into Recovery
    11. From the Utilities menu, select Terminal
    12. At the prompt type exactly the following and then press Return: csrutil enable
    13. Terminal should display a message that SIP was enabled
    14. From the  menu, select Restart.
  • In reply to MEric:

    Thanks MEric for the steps.  This seemed to work and I am not seeing the pop up.

    One minor adjustment to your steps - after step 8 you have to restart and boot back into Recovery (Command-R) again to run the crsutil enable command.   

  • In reply to Kyle Wilson:

    Hi Kyle,

    Thanks for letting me know this worked out for you.  I've updated the steps in my post.

  • In reply to MEric:

    Doh just got the prompt again... ugh...  I guess that did not fix it.  :(

     

  • In reply to Kyle Wilson:

    Terrible experience that this comes up at all, and that the resolution is to have users go through a giant list of steps that may or may not work. Unacceptable UX, totally missing the point of experience design. Don't have time for this. Going to remove the tool and find someone that understands time is valuable, and empathizes with the customer. 

  • In reply to Jasmine Ooi:

    The instructions at this link show what the Allow button should look like: https://support.home.sophos.com/hc/en-us/articles/115005363986-System-Extension-Blocked-appears-on-new-installations-on-macOS-High-Sierra-10-13-and-macOS-Mojave-10-14

    Like everyone else, I couldn't see this either, but then through trial an error, I worked out that if you turn the mac firewall ON, in the tab under firewall, then go back to the General tab, the Allow button should now appear...

    Shame Sohpos didn't make this clear...

  • In reply to dan cox1:

    This never worked either. Has this been resolved yet?

     

    I have tried everything else in the thread so am kind of lost as to how to proceed to stop this annoying pop up happening. Like another user has suggested I may just uninstall it and find another Anti Virus. 

  • In reply to Ror:

    I have the same problem.  New MacBook Pro 16" running Catalina 10.15.1

     

    This should be resolved by a software update, not by making end users jump through hoops, yes?

     

    Might you let me — and us — know when that update can be expected?

     

    With thanks,

     

         H.

  • In reply to Howard Rodman:

    And for what it's worth: I went through all of the steps 1-14 (including the extra step of a command-R boot after step 8).

     

    The pop-up still pops up.

     

    This feels like a Sophos issue, not a Mac issue.

     

    Again: might you let all of us know when you are gong to address it in a new release?

     

    With thanks,

     

       Howard.

  • In reply to MEric:

    I was getting the popup repeatedly too.

    When I get sent to Security and Privacy it's on the RHS Privacy tab. No Allow button.

    When I click on the LHS General Tab there is an Allow button and something about allowing Sophos downloads from a non-Apple site. I forget exactly what it said. 

    I clicked on the Allow button for downloading Sophos from non-Apple site and so far the popup seems to have disappeared.

    Mojave 10.14.6

  • In reply to Nicholas White:

    I did the same.  Allowed downloads from both App Store and identified developers.

     

    Pop-ups continued.

     

    I then uninstalled Sophos.

     

    Problem solved!

  • December 2019 and this issue still isn't resolved. A week ago Sophos released this article: https://community.sophos.com/products/free-antivirus-tools-for-desktops/f/sophos-anti-virus-for-mac-home-edition/109201/how-to-satisfy-a-recurrent-security-and-privacy-pop-up#pi2151=3

     

    It doesn't work on my end. Sophos doesn't appear anywhere in my notifications list. What computer are they testing these on? Where are these magical "allow" buttons and Sophos icons that the rest of us can't access.

     

    Anyhow as others have stated, uninstall Sophos. That's the solution.

  • In reply to Jim Rage:

    OMG I figured this out accidentally, by installing AVG software. What the Sophos instructions (https://community.sophos.com/kb/en-us/134552) fail to mention is that you need to add the Sophos app from the Applications folder to Full Disk Access as well. The Sophos popup fails to do this, and you have to do it manually. Then, indeed, in the General tab you are asked to Allow the app.

    Hope this solves the issue. By the way, Sophos customer service is crap.

  • In reply to A B12:

    Hi  

    Thank you for sharing the steps which helped you to resolve the issue. Apologies for any inconvenience caused.