How to satisfy a recurrent 'Security and Privacy' pop-up?

Hello,

I'm a new member. Joined because I've been clicking ignore for too long on an annoying pop-up and am hoping to actually solve it now. The pop-up states:

 

Sophos Endpoint

You need to change your 'Security & Privacy' settings in order to protect this computer.

Click 'Open Security & Privacy' and then click 'Allow' within the next screen.

 

In theory the next step is easy ... except there is no "Allow" option at the next screen. And so I am left with no choice but to repetitively hit "Close" to ignore the pop-up. I run 10.13.6 (High Sierra) on a 2018 MBPro, in case that helps anyone lead me to an alternative solution.

Thank you in advance for your time and attention.

~Dave 

  • Hi Dave Dudek,

    Can you please type the following command in the terminal window and share the output here? Also, please let us know the Sophos product and the Mac OS details.

    sqlite3 /var/db/SystemPolicyConfiguration/KextPolicy "SELECT * from kext_policy”

  • In reply to Gowtham Mani:

    Gowtham Mani

    Hi Dave Dudek,

    Can you please type the following command in the terminal window and share the output here? Also, please let us know the Sophos product and the Mac OS details.

    sqlite3 /var/db/SystemPolicyConfiguration/KextPolicy "SELECT * from kext_policy”

     

    Hi Gowtham Mani

    I happened upon this thread and I also am having the same problem.

    I copied and pasted the above command into terminal and there was no reaction - just the appearance of another cursor. 

    I'm using Mac OS 10.13.6 and Sophos Anti-Virus home edition 9.7.7.

     

    Is that an indication of some sort in that there was no reaction to the command?

     

    Any other ideas to try?

     

    Thanks for the help.

     

    Bernie

     

     

  • In reply to Gowtham Mani:

    Hi Gowtham!

    I appreciate you responding. I'm not sure how to complete this instruction, however. I'm moderately computer literate and have used command lines before for software requiring Linux (different computer), but I do not see anywhere in the Sophos software where I can type your command. Please advise.

    As for your other questions.

    MacOS: 10.13.6 (High Sierra)

    Laptop: MBPro 2018

    Sophos: "Home Edition version 9.7.7, Threat detection engine: 3.70.2"

    Thank you again for your time,

    Dave

  • In reply to Dave Dudek:

    Hi Dave Dudek,

    As you can see in the thread, I joined in the other day as I came across your issue and I'm having the exact same problem. So, I hope you don't mind if I chime in here.

    I think that the place that has been suggested to place that command line is not in Sophos but in the Terminal app which is part of the Mac OS. You can try that.

    I've tried it and nothing actually happens except the cursor moves to a new line. If you get a result other than that, please post. I may be doing it incorrectly.

     

    Best to you,

    Bernie

  • In reply to Bernie Kirsh:

    Hey Bernie,

    I'm happy to team up! Hopefully Gowtham Mani can help us both.

    As for your comment, which MacOS are you using? Mine does not have the Terminal App as part of its default conditions, so I still cannot comment on that part.

    Genuinely,

    Dave

  • In reply to Dave Dudek:

    Hi Dave,

    I know, I’m with you, there’s comfort in numbers.

    I’m using the latest version of High Sierra.

    As for the terminal app, take a peek in Utilities. That’s where it is in mine. It’s in Applications/Utilities, I believe. I’m not in front of my computer just now.

    Please let me know if you have any luck with it.

    Best-

    Bernie

  • In reply to Bernie Kirsh:

    Thank you, Bennie.

    That was all correct. And, yes, I too copied/pasted Gowtham's command and it turned up nothing. Perhaps there is a typo made by Gowtham that we did not notice?

    ~Dave

  • In reply to Dave Dudek:

    Hi Dave & Bernie,

    Can you try the steps as suggested in the following video and let me know if that helps?

    Check if KEXT is enabled - Just follow it till the time - 1:48

  • In reply to Gowtham Mani:

    Hi again Gowtham,

    Thank you for your time. Unfortunately, those commands do not help. In terminal, even beginning with entering chroot, I have a different outcome than in the video (nothing is accomplished; on the next line, I merely start over), which means that for the next command '/Volumes/' rather than access that directory, Terminal merely acknowledges that it is a directory and again starts over.

    Is there another solution using Terminal or one that does not require use of Terminal at all?

    ~Dave

  • In reply to Dave Dudek:

    Hello Gentlemen,

     

    I, too, have had the same results that Dave has had. The actual working of Terminal with the commands does not conform to the video. 

     

    Anything else to try?

     

    Best,

    Bernie

  • In reply to Bernie Kirsh:

    Hello all,

     

    If I may add my voice to the chorus here. The same issue has recently "popped up" (sorry) on my 2018 Macbook Pro, macOS Mojave, version 10.14.2. 

    Sophos Anti-virus Home edition 9.7.7. I've tried the Terminal work-around to no avail. Hopefully we can expect a software update to address this new glitch? I've been extremely happy with Sophos for several years now.

     

    Cheers,

     

    Chris

  • In reply to Bernie Kirsh:

    Hi Dave, Bernie & Chris,

    If you any of you are using Sophos Home premium, please create a support ticket from you Sophos Home dashboard and let me know the ticket number via PM and I would be glad to work on it & get this sorted for you.

    The requirement to enable the Kext for third-party applications is due to new security changes with Later versions of Mac. If you are ok, you can try to Reinstall from macOS Recovery and then follow these steps to enable the kext in Mac Security.

  • In reply to Gowtham Mani:

    I am seeing the same issue on a Macbook Pro 13 running Mac OS 10.14.2 and Sophos Home Version 9.7.7.  Both the OS and Sophos are reporting they are fully updated.

     

    I get the same message as the others and it recurrs frequently.  As with the others, if I follow the instructions there is no allow option shown, nor is the any reference to a KEXT item shown when I go to the menu item suggested.   The command line run in terminal mode as an admin in Utilities is silent and does not follow up with any return once run.

     

    Any thoughts please?

     

    Thanks!   

     

    Dave

  • In reply to David Somers:

    Hi  

    Can you please confirm me if you are using Sophos Home free version or Home version? 

  • In reply to Gowtham Mani:

    I  am having the same problem as well. Please help me. I've looked at the thread and nothing seems to work for me.