Custom action failed on Installation of SEC 5.3.1

I've built a clean Windows 2012 R2 server on VMWare 6.0 and patched it.

I have turned on the Computer Browser service.

An installation of SEC v5.3.1 fails with the error "Unable to install Sophos Update Manager - A custom action failed"

This error points me at KB article 114627 but this doesn't cover a failure on Sophos Update Manager.

I have an existing SEC server (v5.1) on the network and want to create a fresh install.

Can anyone give me some pointer on how to diagnose and resolve this issue ?

  • Hello IT Services,

    please check the Sophos_Summsi log (in %ProgramData%\Sophos\Management Installer\) - it should contain details on the error.


  • In reply to QC:

    Thanks for the reply, the log contains the following lines -

    MSI (s) (E4:94) [11:58:50:516]: Executing op: CustomActionSchedule(Action=IS_StoreSUMCredentials,ActionType=9217,Source=BinaryData,Target=**********,CustomActionData=**********)

    MSI (s) (E4:D8) [11:58:50:516]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI76FA.tmp, Entrypoint: StoreUserCredentials
    CustomAction IS_StoreSUMCredentials returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
    MSI (s) (E4:94) [11:58:54:859]: Note: 1: 2265 2: 3: -2147287035
    MSI (s) (E4:94) [11:58:54:859]: User policy value 'DisableRollback' is 0
    MSI (s) (E4:94) [11:58:54:859]: Machine policy value 'DisableRollback' is 0
    Action ended 11:58:54: InstallFinalize. Return value 3.

    Could this be related to the fact the database user I'm specifying is in use by my other server ?

  • In reply to ITServices2:

    Hello IT Services,

    thanks for the lines - now, this is a "hidden" action (for whatever reason) and I'm not sure what it does. Seems it's about to write the SUM (not the database) user credentials to system.xml in \Program Files (x86)\Sophos\Update Manager at this point. You did already give it another try?


  • In reply to QC:

    Yeah, I had another go, this time creating a new user but that didn't help, same error.

  • In reply to ITServices2:

    Hello IT Services,

    so it's not a one-time glitch. As said, I don't know what it's supposed to do at this point (can't see why writing the xml file, if this is what it does, should fail). So I think your best option is to open a ticket with Support.


  • In reply to QC:

    Thanks for your help anyway, I was thinking it was looking like that.

  • Can you recall what the solution was at all?


    We have the same error here, at the same place though with v5.5 install rather than 5.3.x


    I'll raise a support ticket but I thought it might be useful to get it in print here.



  • Hi!,

    I don't know if anyone is having the same issue, but the problem is with the password of the SUM account. Any non ASCII character will cause (in this scenario) the problem. Replace any non-ascii/english character and it will work. This is only related to non-english systems (spanish in my case)

    In my case, "backwards" exclamation signs (¡) caused the failure.