Installation de sophos auto update echouée

Bonjour,

Suite à une réinstallation du système d'exploitation des postes clients (windows 10), certains d'entre eux ne parviennent plus à faire la mise à jour echec installation du package MSI Sophos Auto update).

J'ai  tenté une installation en local via chemin UNC mais j'ai la même erreur. Les autres packages s'installent sans problèmes mais pas celui-ci.

7 postes sur 10 sont concernés.

Je n'ai pas de problème réseau ou DNS, le compte utilisé pour l'installation a tous les droits.

Dans le fichier de logs d'Auto uopdate j'ai ce message: "Could not create instance of Iproductsetup2. Reverting to iproductsetup (failure).Installation of product Sophos Autoupdate failed."

Merci d'avance pour votre aide

 

Fred

  • Bonjour and Hello Fred,

    I hope an answer in English is ok (the other option would be German) as my French is more than rusty.

    Could not create instance of Iproductsetup2
    is not the problem, it has always been there.

    It's not a download problem, it's the installation that fails. The relevant MSI log is the Sophos AutoUpdate 5.15.166 install log ......txt in %windir%\Temp\.

    Christian

  • In reply to QC:

    Hi Christian,

    Thank you for your help!

    OK for the answer in english.

    This is the log file you ask:

    03-07-2020 10:31:23 Successfully requested Sophos Endpoint Defense disable tamper protection of SAU.
    03-07-2020 10:31:23 Updating credentials have expired.
    03-07-2020 10:31:23 Adding registry key for SophosAlert.exe: cmd.exe /c IF EXIST "C:\Program Files (x86)\Sophos\AutoUpdate\SophosAlert.exe" start "Sophos" /B "C:\Program Files (x86)\Sophos\AutoUpdate\SophosAlert.exe"
    03-07-2020 10:31:24 Successfully registered for tamper protection with Sophos Endpoint Defense.
    03-07-2020 10:31:24 Error: Unknown exception

     

    Have a nice day.

     

    Fred

  • In reply to dcoop sw:

    Hello Fred,

    03-07-2020 10:31:23 Updating credentials have expired.
    I've seen a few posts (like this one) with this message in the log. It seems that AutoUpdate thinks the license is no longer valid. Did you also get an alert like this one on the endpoints? The article mentions expired credentials for updating from Sophos as cause (though I think updating via UNC should resolve this), the post suggests an outdated version of AutoUpdate as cause (though the updating mechanism is quite resilient and I think this was just a glitch).

    Christian 

  • In reply to QC:

    Hi Christian,

     

    I tried updating from UNC but it still doesn't work.

    My server is not connected to the internet, how can i see if my licence is still valid?

    I didn't install this server and i don't have any document with the licence.

    Thanks.

     

    Fred

  • In reply to dcoop sw:

    Hello Fred,

    updating from UNC
    means: From the Enterprise Console (SEC/SUM) server? And this server has no Internet connection (how would it then get the updates)?

    If you can't find the License Schedule or someone that knows about it please see here.

    Christian