How to uninstall Sophos Management Server

Hello Team,


This is my first post on this community. I hope I can find a solution asap.


I bought a new Sophos version for my Server. Then I tried to uninstall all existing old Sophos applications before I install the new one.


I uninstalled successfully all Sophos apps except Sophos Management Server. This application is can not be uninstalled. I am always facing with the following failure screen;


I tried;

*Uninstall other Sophos apps

*Stop every Sophos services

*Followed instructions in but the regedit file is never exist in there


I will be appreciate if you can support to me.

  • Hi  

    Thank you for contacting us. Kindly please DM us the case# to review the same for you. If no support ticket is created, Kindly please DM me with your available time to assist you further with this issue and I will be glad to assist you with the same.

  • Hi,


    Was there are resolution for this?  As I'm having the exact same issue in attempting to remove Sophos Management Server.


    Many thanks,

  • In reply to Greg Jones:

    Hello Greg Jones,

    exact same issue is easily said give that this is a rather general message. Off the top of my head the management components' MSI packages aren't cached, Uninstall expects them in their original location (\sec_5xx\ServerInstaller\). Dunno if you'd get this message when it's no longer there.
    And normally it should just work - as upgrades implicitly perform an uninstall. Uninstalling from Programs and Features does normally not produce a log, you have to do it from the command line (not recommended for the management components but safe if they are the only ones remaining) requesting logging.


  • In reply to QC:

    Hi Christian,

    Thanks for the guidance.  I've tried to uninstall via the command line as suggested, but I get the same error.  Checking the Event logs I can see a couple of Events.

    Event ID 11721:

    Product: Sophos Management Server -- Error 1721. There is a problem with this Windows Installer package. A program required for this install to complete could not be run. Contact your support personnel or package vendor. Action: RunServerInitUninstall.3E22F2D1_FDCE_4BC2_851A_78461B4146A1, location: C:\Program Files (x86)\Sophos\Enterprise Console\ServerInit.exe, command: -uninstall -logpath "C:\Users\ADMINI~1\AppData\Local\Temp\\"

    When checking the log path I can't find any logs.  However looking for C:\Program Files (x86)\Sophos\Enterprise Console\ServerInit.exe and ServerInit.exe does not exist.


    Event ID:8004

    The description for Event ID 8004 from source Sophos Management Service cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    If the event originated on another computer, the display information had to be saved with the event.

    The following information was included with the event:

    Step: Initializing the Spring.NET Application object
    Error: Runtime error
    Data: 0x80040154 - Class not registered

    the message resource is present but the message is not found in the string/message table


    I'm assuming that in order to uninstall the Enterprise console, I'll need to repair the current installation.  Unless there is a process to manually remove all the components?




  • In reply to Greg Jones:

    Hello Greg,

    ServerInit.exe [...] I can't find any logs
    naturally, as the program didn't run.
    Did you request a verbose log when running msiexec.exe from the command line? Although the significant error is also in the Event Log the additional information from the MSI log is often helpful.

    [is there] a process to manually remove all the components?
    the Windows Installer is supposed to remove them. It's not just deleting this or that. I get it that the server wasn't a dedicated server so it has "things" on it you want to keep?

    Repairing the existing installation or even re-running setup.exe might make it "uninstallable". How many files are in the Enterprise Console program directory, should be over 200. It might or might not suffice to put serverinit.exe back where it should be if everything else is there - though I assume this isn't the case.


  • In reply to QC:

    Hi Christian,



    Thanks for your assistance here.  I've managed to crack this.

    Checking the Enterprise Console Program directory there were 108 items listed.  So I checked the Shadow copies and luckily my oldest one had 215 files in it.  I just plopped all the files back into the directory and the uninstaller has run without issue.

    Not sure if that will help the next person with the issue, and doesn't really explain why they were removed in the first place?


    Again thanks for your assistance, helped me out.