migrating SEC from server to server

Hi,

 

I am in the process of migrating SEC from an old server (2008) to a new server (2012). When I run this command:

 

C:\Program Files (x86)\Sophos\Enterprise Console>DataBackupRestore -Action=Resto

re -DataSourceType=SecureStore

 

I keep getting the following error:

 

 

Build started 08/10/2015 13:44:29.

Retrieving the COM class factory for component with CLSID {2C5339F1-B8D3-4D40-92

45-E68E0F8C6380} failed due to the following error: 80080005 Server execution fa

iled (Exception from HRESULT: 0x80080005 (CO_E_SERVER_EXEC_FAILURE)).

 

Build FAILED.

 

Time Elapsed 00:02:00.11

Process 'C:\Windows\Microsoft.NET\Framework64\v4.0.30319\msbuild.exe "C:\Program

Files (x86)\Sophos\Enterprise Console"\BackupRestore.proj /t:Restore /clp:NoSum

mary /p:SubSystem=all;DataSourceType=SecureStore;ExcludeDB=False;LocationSpecifi

c=False;SlientMode=False;DBServerInstance=' returned Error 1

 

 

could you please assist?

  • Hello zaqwsx1234.

    sorry for the late reply - could you meanwhile solve your problem?

    Now, CLSID {2C5339F1-B8D3-4D40-9245-E68E0F8C6380} belongs to ManagementService.CoreServices and the error suggests that the Management Server component is not (or not properly) installed.

    Christian

  • In reply to QC:

    Hello,

    I'm also struggling with the same migration (win 2k3 -> win 2012r2) and also I'm stuck by the same error message. Does anyone have a solution that works?

  • Can you confirm if you have followed Appendix B Section 18.2 "Modify exported registry files" of the below article?

    www.sophos.com/.../sec_52_mgeng.pdf

  • In reply to WomboCombo:

    I am facing the same issue migration is 64bits to 64bits so no registry keys change is required. Someone know how to fix this issue?

  • In reply to Tom Menezes:

    Hello Tom Menezes,

    as said, it's not the keys. There's no solution reported and I can just repeat my guess that there's some issue with the management server installation. Is the Application {E0992E08-C43F-4419-BDD8-E60F19CB0AA3} listed under Component ServicesDCOM Config?

    Christian

  • In reply to QC:

    I am migrating from Server 2008r2 x64 to Server 2016 (x64).
    After the command DataBAckupRestore.exe -Action=Restore -DataSourceType=SecureStore the build starts and then fails.

     

    Retrieving the COM class factory for component with CLSID {2C5339F1-B8D3-4D40-9245-E68E0F8C6380} failed due to the following error:  80080005 Server execution failed (Exception from HRESULT: 0x80080005 (CO_E_SERVER_EXEC_FAILURE)).

     

    Build FAILED.

     

    Time Elapsed 00:02:00.42

    Process 'C:\Windows\Microsoft.NET\Framework64\v4.0.30319\msbuild.exe "C:\Program Files (x86)\Sophos\Enterprise Console"\BackupRestore.proj /t:Restore /clp:NoSummary /p:SubSystem=all;DataSourceType=securestore;ExcludeDB=False;LocationSpecific=False;SilentMode=False;DBServerInstance=' returned error 1

     

     

     

    Inside my Component Services -> Computers -> My Computer -> DCOM Config, there entry {2C5339F1-B8D3-4D40-9245-E68E0F8C6380} is not present.

    Perhaps of note, I do have the mentioned application {E0992E08-C43F-4419-BDD8-E60F19CB0AA3} listed. Not quite sure how to read Component Services, so i don't know what this translates to.

     

    Thanks all

  • In reply to Chris Carson:

    Hi  

    As per the logs, it seems the DatabackupRestore tool is not being able to access the database. Could you please check this article and see if it helps you to resolve the issue.