Windows 10 update blocked internet

Hi

Today the automatic update of Windows 10 occurred on my home desktop (which is protected with Sophos Endpoint Security and Control Version 10.6) , and tonight I am unable to access the internet.  Upon opening Google Chrome I get the error message "Your Internet access is blocked, Firewall or antivirus software may have blocked the connection", then when clicking on Diagnose Errors it says, "One or more network protocols are missing on this computer".  I briefly turned off the firewall, opened the internet and it came up as normal and I was able to use Chrome.  I turned the firewall back on and the access was again blocked.  I would be grateful for any recommendation to solve this.

Thanks

Paul

  • Right-click the Start button at the bottom-left corner of your screen or press Windows Key + X and select Device Manager to launch the Device Manager. Locate the device whose driver you want to uninstall, right-click it, and select Uninstall. Check the “Delete the driver software for this device” option and click OK. Windows will uninstall the device and delete the driver software downloaded from Windows Update. You can install fresh drivers software afterwards. To access this option, open the Control Panel by right-clicking the Start button and selecting Control Panel. Navigate to System and Security > System > Advanced system settings. Click the Hardware tab, click Device Installation Settings, and select the “No, let me choose what to do option. Select “Never install driver software from Windows Update.”

  • Right-click the Start button at the bottom-left corner of your screen or press Windows Key + X and select Device Manager to launch the Device Manager. Locate the device whose driver you want to uninstall, right-click it, and select Uninstall. Check the “Delete the driver software for this device” option and click OK. Windows will uninstall the device and delete the driver software downloaded from Windows Update. You can install fresh drivers software afterwards. To access this option, open the Control Panel by right-clicking the Start button and selecting Control Panel. Navigate to System and Security > System > Advanced system settings. Click the Hardware tab, click Device Installation Settings, and select the “No, let me choose what to do option. Select “Never install driver software from Windows Update.”

  • In reply to richardsonkane:

    Thanks very much for your reply Richard.  I am a bit of a novice when it comes to this stuff, so please bear with me!

    I take it that you are suggesting that one of the device drivers is blocking the internet access.  Is there a way for me to identify which one it is?  The error messages that I get when trying to access Chrome don't give me any lead on that.

    Thanks heaps

    Paul

  • In reply to PaulHoney:

    I have just turned off Sophos Firewall and turned on the Windows Firewall. I noticed that one of the Windows Firewall settings is "Outbound connections that do not match a rule are allowed".  In Sophos Firewall this was not the case - the default setting is "Block by default - all traffic which has no matching rule is blocked".  I have not been getting the prompts to add Checksums for new applications since the upgrade to Windows 10.  Should I select the option "Allow by default - outbound traffic which has no matching rule is allowed" in Sophos?  This would seem to be the same as the Windows rule.

    Your thoughts?

    Thanks

    Paul

  • In reply to PaulHoney:

    I have the same problem (installed Windows 10 Enterprise, then Sophos Client Firewall and then got no internet access).

    But I think, it hasn't something to do with the working mode "block by default", since it is the most secure working mode and published from Sophos as "best practise setting":

    https://www.sophos.com/de-de/support/knowledgebase/57757.aspx

  • In reply to MatthiasMüller:

    I have now given up with sophos it didn't matter how many names I added to the approve list but eventually both Chrome and then Edge stopped accessing the internet. Removing and re-loading Chrome made no difference at all and eventually my Laptop was less than useless as virtually every system including Sophos required internet access to update or run. Even steam stopped working. So I have removed Sophos completely and now everything runs as normal!!!! 

    Good bye and good riddance Sophos. I advise any one with similar issues to follow my lead 

    Dave F

  • You need to add  x:\Windows\System32\svchost.exe to the allowed connections.

    Make sure all possible notifications are checked in "configure firewall" as there no longer seems to be an "interactive mode" for the Sophos firewall when installed on a Windows 10 PC. My own Windows 10 is a clean install on a PC that had no previous version of Windows anywhere.

  • Thanks very much for your reply Richard.  I am a bit of a novice when it comes to so please bear with me!

  • In reply to AJ Singh:

    As there is no interactive mode on Windows 10, you have to use the Firewall Event logs to know what to create rules for.

  • I have the same issue. Still haven't figured it out. Help would be appreciated.

     

    Private Training Kuwait

  • In reply to Sarun Jobi:

    Help is not in abundance obviously but am looking forward to an answer if they can.

  • In reply to Sarun Jobi:

    Hi Sarun and Benjamin,

    May I please request you to kindly confirm if Sophos Client Firewall is causing this issue? Can you please confirm if windows Firewall is turned off (if Sophos Client Firewall is preferred by you) and please check if the issue still comes up? If Firewall is the reason, We will have to investigate further and configure rules to allow the updating. Can you help us with the screenshots of the Firewall rules so that we can have a look at the same for you and discuss what additional rule configuration could possible help us here. Alternatively, You can create a support ticket with us to ensure this is discussed over a remote session and call if required.

    • Thanks very much for your reply Richard.  I am a bit of a novice when it comes to so please bear with me! P/s: bacsiphukhoa