Sophos Endpoint on Fedora 27/28 Mount errors after update

SAV: 9.15.0, Engine: 3.72.1, Data: 5.55

I have recently carried out a savupdate on a Fedora 28 kernel Linux 4.18.12-200.fc28.x86_64.

The installer then compiled a local Talpa Binary pack apparently successfully.

The scanner appeared to be operational in ‘ps’ with the processes running correctly.

When I tried to mount a drive the following error occurred.

mount(2) system call failed: Bad address.

The automatic updating of the system was also affected with the following error

Failed to mount per-user tmpfs directory /run/user/0: Bad address

The Pulse Audio detection of the sound card also was not discovered.

I turned off the scanner with the command

./savdctl disable

and the problem was resolved.

I have also issued the command ./savdctl disableOnBoot savd

Any suggestions or should I just enable fanotify’ ?

  • Hello MikeEccy,

    carried out a savupdate
    you have automatic updates disabled? There hasn't been a significant update to the software in the last months AFAIK. You did not update Fedora or the kernel, did you?

    Perhaps has a suggestion.

    Christian

  • The version of Talpa shipped with SAV doesn't support kernels >= 4.17

     

    The version of Talpa in github can now support kernel 4.17, it can be deployed using https://gist.github.com/paperclip/7892031

     

    Otherwise you can use fanotify instead.

  • In reply to QC:

    Hi Christian,

    Autoupdate was turned on but not working.

    In truth sometime back I installed Sophos Linux Endpoint on my home machine to test it for my main Centos 6 workserver.

    I purchased a commercial license for the work server and it uses the pre-compiled Talpa binary packs without issue.

    I posted this message as I found the errors were bizarre and it may help someone at some later date.

    Douglas Leeder's suggestion corrects the problem on my home machine.

    Thanks for your help.

    Mike

     

     

     

  • In reply to DouglasLeeder:

    Hi Douglas,

    I have carried out the instructions following your link, the Talpa binary compiles and loads correctly.

    I will also create a cron as you suggest which should keep up to date with any further kernel updates.

    Thank you for your help.

    Mike