Community site plain out does not work on Chrome

I am not sure if this is just me, but community.sophos.com is absolutely unusable on Chrome browsers. Page load times are about 15 seconds per page and a lot of buttons (like reply to post or send) don't work at all.

Don't want to rule out my system but I have no such issues with other websites (and I use a lot). 

Safari and Firefox on the same computer work just fine. 

  • I cannot speak for the OSX version of Chrome but I have been using the Windows version for awhile now and had no issues, accept for last week but they had a banner stating they were having issues with the site then.

  • I can confirm that Chrome doesn't work here in the Sophos Community Forums.

    It is slow and many functions simply doesn't work.

    For example I cannot post anything with Chrome. On new Posts the "Post" button doesn't work. When I click it, it simply jumps to the top of the page. And on existing Posts the "Reply" button doesn't work at all. It simply does nothing. The other Buttons "This helped me" or "More" also won't work.

    Can we please go back to the old Astaro-Forum?

     

    PS: This post was written using an old Internet Explorer :-D

  • In reply to ipzipzap:

    Hi All,

    We have tested the Sophos Community on different OSes and browsers and where we find a particular issue we can resolve it.

    While I'm not doubting you may be experiencing an issue, as this thread hasn't had hundreds or even tens of '+1' votes etc., I'd say (for now), it is something local to you.  Some extension misbehaving?  Some setting causing an incompatibility?

    First checks I'd suggest:

    1. Check you have what version of Chrome you have installed.  Is it the latest?  Obvious to say, but needs to be confirmed.
    2. With Chrome active open a new incognito window (Ctrl + Shift + N for Windows for example).  Close ALL other tabs/browsers with the Sophos Community and solely browse this site using that incognito window for a day.
    3. I'd then suggest reseting your browser.  Clearing the cache and cookies of everything may help, but to really clear out any incompatible changes maybe reset from the Settings menu (chrome://settings/resetProfileSettings?origin=userclick)

    If the problem continues, I'm willing to try and recreate but I will need a list of extensions that are installed.  If it turns out that an extension is incompatible (You don't have uBlock Origin installed and active for example?) then the workaround is to whitelist the Sophos Community site or disable the extension during the session if that option is not available.

  • In reply to ruckus:

     this seems to be a common trend across your web services though. Not sure how you test this, but I have a pretty plain and vanilla Chrome.

     

    Today, I tried registering on cloud.sophos.com with Chrome. No chance. Doesn't work. After confirming the account I am redirected to https://cloud.sophos.com/manage/login which is just a completely empty page.

     

    Also today, I tried running the setup wizard on a XG135, which was a hot mess using Chrome. Got stuck on multiple screens. Turned out that wizard doesn't like Chrome, either. 

     

    Maybe just trust your users with their reports instead of asking them to do the troubleshooting for you. For me it is quite simple: I am going to use products that work with Chrome. 

  • I must say this is true upto a certain extent, i also faced problems while loading the page. I used this page (https://routerlogin.one/192-168-0-2/) and did not face the other issue but i guess VPN may be the reason, try to load the page with no VPN.

  • In reply to clency tom:

    Ok, so it turns out this site is really sensitive when it comes to Adblockers. I was able to completely get rid of the issue by disabling my Adblocker for community.sophos.com.