No Update since days and where are the Sophos Anti-Virus threads

Hello,

First of all, where are the Sophos Anti-Virus threads in this forum ? I do not know where to post this. Sorry about this.
Then, I hope someone will answer that issue before I delete that program; I saw many others had the problem and never found out what to do.

I am using MacOS 11.6 (Big Sur) on Intel. I run Sophos Anti-Virus 9.10.3. I did not install that software myself.

— Updates worked for a day, not more.
— The update location is "Sophos" using my credentials in the AutoUpdate Preferences panel. No proxy.
— I get the following error:
"Could not contact primary server"
— The log says:
"com.sophos.autoupdate: Proceed with manually triggered update from Sophos"
"com.sophos.autoupdate: Error: Update cancelled"
"com.sophos.autoupdate: Error: Could not contact primary server at"
"com.sophos.autoupdate: URL is invalid"

<- Proceeding with manually triggered update does not work. I use "Update Now".
<- Since it was working fine for a day I suspect the server is down and the information is not accurate. OR I need to do something I am not told to finalize the registration and the information is not accurate. It took me a while to realize I had to register myself on Sophos and log-in in the AutoUpdate Preferences panel in order to get updates working the first time.
<- Should I wait or do something ?

Thank you very much for your help !!! Slight smile