Big Sur 11.2.3 - Intercept X 10.0.4 - Adobe InDesign opening files as read-only

Big Sur 11.2.3 - Intercept X 10.0.4 - Adobe InDesign opening files as read-only. As a workaround, I go to the Mac, login with the Tamper protection password, then go to settings and disable Ransomware Detection (CryptoGuard). This is not ideal. I have added InDesign as a global exclusion but that didn't fix it. If anyone else has come across this please let me know.

Parents
  • Getting this exact issue with InDesign on 3 new iMac machines with Big Sur installed.

    Looks like opening a case with Sophos as well as trying to add exclusions that work seems to be a nightmare.

  • Finally, LOL. The InDesign files are stored on our Synology NAS. We think this is a combination of Sophos, Synology's file system and maybe SMB and Apple. You can make all the Exclusions you want, they will not help because exclusions are only for Antivirus.

    I have been going back and forth with them for a month. Here is their last response:

    Hello Jeff,

    As we discussed, unfortunately this is an issue we're not able to affect on our end as the underlying file system protocols and extensions are controlled by Apple. There is no configuration of the Sophos Endpoint that we can say will resolve file locking issues while using Adobe or other software.

    Please let me know if you have any other concerns or need further clarification.

    Otherwise we will mark this case closed as an unresolved environmental issue.

    Regards, 

    Ian Diminie 
    Sophos Technical Support Escalations

    The 4 computers that are affected here are in their own Policy with Crytoguard turned off. Not sure what else to do. I sent this to our reseller and to the Sophos Professional Services Engineer that I did my training with. They are going to try and get this to the Global Escalation Team.

    We also have a problem with 4D databases that are on the Synology. They are opening as write-protected and we cannot edit them. I have to completely uninstall Sophos to get them to open. Both 4D and InDesign files work fine when you open them locally.

  • Ours are using SMB on a Windows Domain network so NTFS volumes.
    Open locally fine as well, so common issue seems to be network located files.

    If I get anywhere other than the current option, I'll try and reply back.

  • Great. I was just about to reopen my ticket with Synology. Please let me know if you get anywhere.

  • Andrew, Here is supports latest response:

    Hello Jeff,

    This seems like an InDesign issue and should be brought up with their support team.

    Our investigation suggests that InDesign is likely not waiting for OPLOCK to be released on a file before opening it, hence it can only work in read-only mode.

    Cryptoguard may be incidentally adding additional wait time before OPLOCK is released by the system, since we're touching the file, but we're not directly affecting InDesign's file access logic at all.

    Most applications check the OPLOCK status and wait until they have write access before opening a file.

    Regards, 

    Ian Diminie 
    Sophos Technical Support Escalations

Reply
  • Andrew, Here is supports latest response:

    Hello Jeff,

    This seems like an InDesign issue and should be brought up with their support team.

    Our investigation suggests that InDesign is likely not waiting for OPLOCK to be released on a file before opening it, hence it can only work in read-only mode.

    Cryptoguard may be incidentally adding additional wait time before OPLOCK is released by the system, since we're touching the file, but we're not directly affecting InDesign's file access logic at all.

    Most applications check the OPLOCK status and wait until they have write access before opening a file.

    Regards, 

    Ian Diminie 
    Sophos Technical Support Escalations

Children
No Data