How to satisfy a recurrent 'Security and Privacy' pop-up?

Hello,

I'm a new member. Joined because I've been clicking ignore for too long on an annoying pop-up and am hoping to actually solve it now. The pop-up states:

 

Sophos Endpoint

You need to change your 'Security & Privacy' settings in order to protect this computer.

Click 'Open Security & Privacy' and then click 'Allow' within the next screen.

 

In theory the next step is easy ... except there is no "Allow" option at the next screen. And so I am left with no choice but to repetitively hit "Close" to ignore the pop-up. I run 10.13.6 (High Sierra) on a 2018 MBPro, in case that helps anyone lead me to an alternative solution.

Thank you in advance for your time and attention.

~Dave 

  • Hi Dave Dudek,

    Can you please type the following command in the terminal window and share the output here? Also, please let us know the Sophos product and the Mac OS details.

    sqlite3 /var/db/SystemPolicyConfiguration/KextPolicy "SELECT * from kext_policy”

    Regards,

    Gowtham Mani
    Community Support Engineer | Sophos Technical Support

    Knowledge Base  |  @SophosSupport | Sign up for SMS Alerts
    If a post solves your question use the 'This helped me' link.

  • Gowtham Mani said:

    Hi Dave Dudek,

    Can you please type the following command in the terminal window and share the output here? Also, please let us know the Sophos product and the Mac OS details.

    sqlite3 /var/db/SystemPolicyConfiguration/KextPolicy "SELECT * from kext_policy”

     

    Hi Gowtham Mani

    I happened upon this thread and I also am having the same problem.

    I copied and pasted the above command into terminal and there was no reaction - just the appearance of another cursor. 

    I'm using Mac OS 10.13.6 and Sophos Anti-Virus home edition 9.7.7.

     

    Is that an indication of some sort in that there was no reaction to the command?

     

    Any other ideas to try?

     

    Thanks for the help.

     

    Bernie

     

     

  • Hi Gowtham!

    I appreciate you responding. I'm not sure how to complete this instruction, however. I'm moderately computer literate and have used command lines before for software requiring Linux (different computer), but I do not see anywhere in the Sophos software where I can type your command. Please advise.

    As for your other questions.

    MacOS: 10.13.6 (High Sierra)

    Laptop: MBPro 2018

    Sophos: "Home Edition version 9.7.7, Threat detection engine: 3.70.2"

    Thank you again for your time,

    Dave

  • Hi Dave Dudek,

    As you can see in the thread, I joined in the other day as I came across your issue and I'm having the exact same problem. So, I hope you don't mind if I chime in here.

    I think that the place that has been suggested to place that command line is not in Sophos but in the Terminal app which is part of the Mac OS. You can try that.

    I've tried it and nothing actually happens except the cursor moves to a new line. If you get a result other than that, please post. I may be doing it incorrectly.

     

    Best to you,

    Bernie

  • Hey Bernie,

    I'm happy to team up! Hopefully Gowtham Mani can help us both.

    As for your comment, which MacOS are you using? Mine does not have the Terminal App as part of its default conditions, so I still cannot comment on that part.

    Genuinely,

    Dave

  • Hi Dave,

    I know, I’m with you, there’s comfort in numbers.

    I’m using the latest version of High Sierra.

    As for the terminal app, take a peek in Utilities. That’s where it is in mine. It’s in Applications/Utilities, I believe. I’m not in front of my computer just now.

    Please let me know if you have any luck with it.

    Best-

    Bernie

  • Thank you, Bennie.

    That was all correct. And, yes, I too copied/pasted Gowtham's command and it turned up nothing. Perhaps there is a typo made by Gowtham that we did not notice?

    ~Dave

  • Hi Dave & Bernie,

    Can you try the steps as suggested in the following video and let me know if that helps?

    Check if KEXT is enabled - Just follow it till the time - 1:48

    Regards,

    Gowtham Mani
    Community Support Engineer | Sophos Technical Support

    Knowledge Base  |  @SophosSupport | Sign up for SMS Alerts
    If a post solves your question use the 'This helped me' link.

  • Hi again Gowtham,

    Thank you for your time. Unfortunately, those commands do not help. In terminal, even beginning with entering chroot, I have a different outcome than in the video (nothing is accomplished; on the next line, I merely start over), which means that for the next command '/Volumes/' rather than access that directory, Terminal merely acknowledges that it is a directory and again starts over.

    Is there another solution using Terminal or one that does not require use of Terminal at all?

    ~Dave

  • Hello Gentlemen,

     

    I, too, have had the same results that Dave has had. The actual working of Terminal with the commands does not conform to the video. 

     

    Anything else to try?

     

    Best,

    Bernie