This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Windows 10 RDP Redirected Printing Errors - After Update Installed

I have a user who prints to her home printer while connected via RDP to her work PC.  Both home and work PCs are Windows 10, latest 1903, all updates.  Printer is your basic Officejet Pro 8600.  This worked without issue until I updated her client to version, including the 1901 hotfix.  It was impossible to resolve the issue until I fully uninstalled Sophos Encryption.  I tried everything, including turning office Remote Easy Print via GPO and going with the local drivers, matching exactly.  Same issue.  It instantly fails on the office PC, with an immediate error.  Nothing ever makes it to her home PC printer, via print queue, etc.   As soon as I fully uninstall Sophos / Decrypt system, etc.....all RDP printing works to her home printer from her work PC, via RDP.   I re-installed everything again, printing fails.  So I know it's something with the encryption / Sophos Safeguard.   I hate to roll her back to the older version, which I think was 8.0 something...but I may have to if there's no help.

Anyone see this issue or have ideas?

This thread was automatically locked due to age.
  • Hi  

    Is it giving you any error message? Could you please try the steps provided in this article and see if you are able to print with Safeguard installed? Also,for testing purpose give it a try by excluding the mapped drive for the printers in the File Encryption policy and see if the behavior continues.


    Community Support Engineer | Sophos Technical Support
    Support Videos | Product Documentation@SophosSupport | Sign up for SMS Alerts
    If a post solves your question use the 'Verify Answer' link.


  • They do have file encryption enabled, but are not using it.   Ironically, they will be soon and that was a feature I added recently to all of their workstations.   But again, I have not enabled any file shares yet.  Let me try the steps from that article and get back to you.   Here is the error, which does appear to be exactly the same as described in the article.  They are on 8.10 already.


  • Hi  

    We understand your concern regarding the version as well but the problem may occur due to the subversion of the 8.10. I'd request you to apply the workaround mentioned in the KB article suggest by  however, I'd request you to open a support case here as the KB is specifically for the error which appears when files are on network share and they are encrypted.

    Once the case has been opened, please PM us the case number, so we can monitor the case and also mention the steps you followed while troubleshooting the issue in the case.


    Community Support Engineer | Sophos Support

    Sophos Support VideosKnowledge Base  |  @SophosSupport | Sign up for SMS Alerts |
    If a post solves your question use the 'This helped me' link

  • The KB article steps did not fix the problem.  I have opened a case with your online support and am awaiting confirmation of a case number.

Reply Children
No Data