Cannot uninstall Sophos Home Premium

I tried everything I could find to remove this software as it is not working at all.  I pointed the system to a virus and nada.  Uninstall starts with "Disabling Tamper Protection" and it opens the console.  There is no 'Troubleshoot' option available at the bottom of the window as so many articles point out.  I am logged in as an administrator and I have tried to run the console locally as Administrator but still cannot find 'Troubleshoot'.  I logged a ticket and got an auto response and ref number but nothing after that despite sending a number of follow up emails.


I searched for Sophos removal tool but cannot find any.  I booted into safe mode, disabled all Sophos services then renamed the Sophos folders under Program Files...  When attempting reinstall after this, I get the error for pending restart.  I have followed tech articles that point to deleting / modifying registry keys but either the keys are not there or I get access denied on the Sophos keys.  I tried changing ownership so I can clear Sophos from my registry but again get access denied.


Does anybody know what else I can do as I have no protection on my computer and I cannot install any other product to replace Sophos home as it will not remove.

  • Sorry, System is Windows 10 Professional (build 17763)

  • Is there nobody that can assist?  How is it possible that I, with an admin account, cannot uninstall software that I installed?  Sophos watchers / staff hanging round here?  Anybody??

  • In reply to ZenecadE:


    Could you please check this article and see if it helps? If still, you are facing issues, I would request you to provide the screenshot of the error message you are receiving while you are trying to uninstall.  

  • In reply to Shweta:

    I have mentioned this to the support engineer and I will say this to you as well, I have tried all related articles known to human kind, supplied by Sophos.  NON OF IT WORKED OR WAS APPLICABLE.  I Followed the steps detailed in that article 4 times and there was no change in the result.


    I booted the system with a live Linux cd, then manually deleted Sophos folders.  I then remote edited the registry to delete the Sophos registry keys.  After deleting over 200 keys, Sophos is "off" but will not reinstall.  When I start the installer, it ends with Sophos cannot be installed.  No error, no clue just it won't.  I installed Forticlient with no hassles and this workstation is protected by that provider now.  I cannot believe how pathetic the less than premium support I am getting, even when logging a ticket through the correct channels.  I spelled out exactly what I have done and they reply was to do it again.  WTF???  Sit in your chair and look in the palm of your left hand... Is the hope Diamond there in the palm of your hand?  No?  OK, wait one minute then look again.  Sophos, shame on you.  Luckily this happened to me.  As of 2020, I will not renew any of my nor my customers products thanks to how you support your customers.  You have no shame!!

  • In reply to ZenecadE:


    I sincerely apologize for the inconvenience caused. Could you please PM me the case details you have registered with support so that I can follow up this with the concerned team?  

  • In reply to ZenecadE:

    I had a similar issue, it ended up taking a registry cleaner like CCleaner to fully remove all the registry keys, then I was able to reinstall.